Circles are not parallel (when the lasers changes direction from clockwise to counter clockwise)

Hi Guys,
I have the following problem: When doing circles they are not getting parallel. I have a file, which contains 8 circles. I created 4 circles, then made 8 of them with the offset tool and used an offset of 0.5mm. Lightburn makes the laser move some circles clockwise some counter clockwise. When the laser moves clockwise for both close lines they are parallel. When the laser moves one line clockwise and the other counter clockwise they are not parallel. You can see this at the pictures attached (hope you can understand what I am trying to explain :slightly_smiling_face:)
Here is video to show what I’m meaning: Video

This problem always happens at the same position of the circles. It also does not matter where I’ positioning the material inside the frame.

I have two separate laser machines and both are showing the exact same behaviour. Because of that I am pretty sure that it’s not caused from a mechanical problem.

This behaviour also happens when using offset fill. I attached a picture of this too.

Any help is very much appreciated. I have tried everything and really have not any ideas left.
PS: For me it would also absolutely be ok, if there was an option to tell Lightburn to do circles only in one direction. But I was not able to find a possibility to do this.

Best Regards,
Ben


Click the icon highlighted on the left and your circle. Then hold down shift and click on the arrow and it will change direction and make the laser go the other way.

Mike thank you very much! This quite helps a lot if using the “line” mode.
Unfortunately it has no impact when using offset fill - the laser is still going both direction for every circle.

Oh, well how about don’t use offset fill and just use fill?

Sure, thats one way to solve it. But there’s one big disadvantage: The total estimated time.
Offset Fill: 1:27 Min
Fill: 11:59 Min

Ya, just bit of difference.
What if you offset .01 5 times and didn’t use any fill?

Ya, could be one way to do it.
But only if you create the graphic on your own in LB. If you import a vector file into LB and want to choose offset fill the problem still exists.

Which two engravers are you comparing? What have you selected for your traverse and engrave speeds?

It almost appears that the ‘lead-in’ or ramp-up is happening early on the first engraving.

Hi John,
I’m comparing two lasers of the same model. Both lasers are a Sculpfun S10. I have ordered an additional S10, because I wasn’t able to fix the problem with the first one. But then I noticed that the second S10 also has the same problem.

The used speeds for the fill and also the line was 2400 mm/min. I have not activated lead-in in the layer settings.

2400mm/min might be a touch fast.

Are you willing to share the Machine Settings report from the Console window?
If so, at the Console window enter the following,
$$
then press enter.

Please Copy and Paste that report into a reply here.

This happens also when going with 600 mm/min.

Here are my settings:
$$
$0=10
$1=25
$2=0
$3=0
$4=0
$5=1
$6=0
$10=1
$11=0.010
$12=0.002
$13=0
$20=0
$21=1
$22=1
$23=3
$24=75.000
$25=1000.000
$26=250.000
$27=3.000
$28=1500.000
$30=1000.000
$31=0.000
$32=1
$38=1
$40=1
$100=80.000
$101=80.000
$102=250.000
$103=100.000
$104=100.000
$105=100.000
$110=5000.000
$111=5000.000
$112=1000.000
$113=1000.000
$114=1000.000
$115=1000.000
$120=250.000
$121=250.000
$122=1000.000
$123=200.000
$124=200.000
$125=200.000
$130=395.000
$131=378.000
$132=200.000
$133=300.000
$134=300.000
$135=300.000
ok

Did you check the mechanics carefully? Sometimes, the grub screws holding the pulleys on the motors are not fastened enough. This could lead to some backlash if the laser changes direction.
Here is a guide to go through: Guide to mechanical adjustments and maintenance
Make sure the linear rail is running fine and the y-axis wheels and belts are tightened correctly.

I did check everything several times. Also I think it would be a very big coincidence if two lasers had the exact same mechanical problem…

That’s true, but on the other hand, if both are produced the same way and set up the same way, it might happen. So for example, if you tighten the belts too much, you might did it on both. Not saying that you did. But to me, it looks like a mechanical problem. I would be very surprised if a software setting can cause this.

For sure, you are right. But I really checked everything a lot of times. For example, I tried tighten the belts very strong and then checked the result. Then I tried tighten the belts very soft and checked the result. Same with the wheels and the eccentric nut. And no matter what I have done, the result was always the same.

I will try to do the same test with my S10. Maybe I just didn’t notice so far :slight_smile: Could you upload the file?

Oh that would be awesome. I did not have the possibility to compare to a S10 from another user yet. Thank you very much.
Here is the file:
Unrunde_Kreise.lbrn2 (67.0 KB)

I’d say mine looks ok. I didn’t change the settings from the file. The laser used the same pattern as in your video - the outer circles were done in two directions each.

Ya, looks a lot better!
Can you please check (with the help of the preview tool of LB) if your laser is changing the cutting direction of the circles?

And thanks for your efforts!

Do you use a Windows PC or a Mac (I’m using a Mac)?

Yes, it did. The movement looks identical to your video from the beginning.