Circles not completing (but are round)

Circles not cutting 360 degrees. Gap increases as speed goes up, decreases as power goes up.

My best guess is this has to do with minimum power settings, but I can’t work out how. The rest of the 20-30 circles cut fine on this test cut piece and the laser works great. Just these test cuts don’t seem to cut correctly at these power/speed settings. (10-15% power shown)

I found this post: Squares and circles not complete - #4 by Hank
As the mod said, it’s a bit confusing. I changed my start speed from 8 to 0 and my laser autocorrected to 20. 20 didn’t work. I set to 1 and it wouldn’t even frame properly so I didn’t even try it. I’m set back to 8 for now.

Someone suggested overcut settings. 4mm worked but that felt more like a hack than the right setting and it slightly burnt some of the circles that did finish fine before.

You lost me on this one… what do you mean? And how do you know it did this?

I don’t know of any controllers that auto correct their own configuration… that would be sweet…

How about a photo…? It’s worth 1K words… at least…


I meant that it didn’t like 0 as a setting and defaulted to 20. However it shipped with the setting as 8. So I went back to 8.

Not sure I can post this here but I’ll try. Here is my reddit post about it and it has the picture.

I understand… The Ruida generally won’t take a zero value for some things… Even the maximum/minimum power range is 1 to 99, not 0 to 100…

There no reason you can’t set it to 1… however that doesn’t sound (or look) like your problem here.

You can try, it depends on you level in the sites software (Discourse) … New users have a more restricted ability as to how often and how many they are allowed to post.

There is a list of file types that are allowed, you can drag and drop then on the reply window… alternatively, you can use the upload icon in the tool bar.

Files such as .lbrn, .lbrn2, png, jpg and txt file are allowed. Anything has to be < 4mb in size. If you attempt to upload some alien file type, it will tell you that it doesn’t like it and which file types can be uploaded.

It’s common for a .pdf file to append a .txt for a .pdf.txt file that can be dropped on the reply window. It needs to be renamed when it reaches it’s destination.

If the file is larger than 4mb, you can put it on something like google drive and just post the link here…

Post a photo or a link, apply some patience and wait for the system to accept it and upload it before dropping another photo or file…

Back to your problem…

I noticed it’s rather randomly distributed around the circle. When it runs are these gaps at the start/stop points?

If this is the case, why does the left circles have a seemingly consistent gap?

Until we find the cause, I can only suggest that you try to add a lead in/lead out in the layer and see if that effects the gap. You shouldn’t have to make these hacks as you refer … I think you’re right about that.

My Ruida isn’t powered up, so I can’t access it (garage), but I will check later for anything that I think may cause this. A circle, I would think would run at the same speed, except maybe at the beginning and end… When I run mine, I see the same speed, but it could be fooling me… wouldn’t be the first time…

Good luck


Yes at the start/stop. (I believe start, but it’s hard to tell)

It seems like there has to be a setting for once it stops firing and moves to a new location that it would stop, fire, then travel so this didn’t happen. I’ll have to go over the documentation this weekend and see if I can find something.

But my hunch is:

I think since the laser stops firing below 10% whatever ramp-up it’s using is falling below that initially. That explains why it only happens at 10-20%, why the gap is wider at faster speeds, and why the gap gets smaller with higher power. I think shape properties is handling the minimum power differently than the layer. All layer cuts without shape properties are cutting fine because they are obeying the min power settings set by the layer. I just don’t know where to find that setting.

This is my best guess at least.

An easy fix/check, is to set minimum and maximum power to the same value… if this is the case it will complete the circle… and you will have identified the issue.

I’ll go fire up the Ruida and see if I can see anything else that my help…

I looked and the only thing I can see that might cause issues in under the Laser settings of the Ruida is if you are using a glass tube or a metal tube rf laser…


  1. see if setting minimum power equal to maximum power on the layer
  2. does it look like it’s slowing down when it’s in this area?
  3. ensure you’re set to glass tube in the device settings

Good luck


1 Like

Hah! You found the exact setting I was looking for according to my hunch. My minimum power % was set to 1. I changed it to 10 and boom, closed circles. Thanks so much!

1 Like

I’m glad it’s doing what it should…

Many dc excited co2 lasers will not lase below around 10%. Mine won’t go below 9% depending on the temperature…

Some of the commercial tubes, for example a 60W I’ve seen, states that it’s minimum power is 12W, indicating they recommend a minimum power setting of 20%.

Take care


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.