Circles not round, Oval

My NEJE Master 2S plus 30 Watt is cutting OVALS and not CIRCLES. Software is Lightburn 1.0.02 with both height and width set at 50mm, I will get an oval with x=49.5 and y=53.0mm. I tried to tighten both x and y belts. Both felt tight but I pulled a little harder anyway. It did not help. Is there a procedure I should follow to tighten the belts or is there another adjustment I should try?

Is there any settings in LightBurn that could cause this? Is there some type of calibration that is needed like the one for the camera?
Just searching for answers.
Wayne

Check your machine settings to make sure your X & Y parameters match (except X Max and Y Max):
Edit->Machine Settings

If they match then maybe you are trying to run faster than your acceleration setting is permitting. What are your cut speeds? What happens if you cut the speed and power in half?

Thank you for the response.The settings for my machine are =255, y=420 which is the correct size of my machine. I hope this is what you were asking for. I cut my speed and Any thing else I should try.power in half to 350 mm/min and 20%.There was no change and I still get oval circles. I confirmed that I have the latest versions of NEJE and LightBurn. Any thing else I chould try?
My settings:

Well, you could try to set X Acceleration to 250 to match the Y acceleration, but given the relatively low speed that you’re moving, I don’t have much hope that that will make a significant change. Be sure to save the new setting to your machine before you try it.

One thing you could try is to make a square (large enough that you can measure it accurately) and make sure it comes out square. Who knows, maybe one of the pulleys (X vs Y) is machined incorrectly (I know this NEVER happens :crazy_face: and one axis is moves less than the other.

Thanks, I will give that a try tonight.
Wayne

Well crap, I tried to engrave a 100 x 100 square at 700 mm/min and power of 40% and on the x axis I got 100 mm and 107mm on the Y axis. Both the top and btm of the square were 100 mm wide (x axis) and the both left and right sides (y axis) were 107mm. So that would indicate there is no tapper in the square.
)
I also went into the latest version of the NEJE software (I hate it BTW.) and entered a 50 mm square and got all sides of 50 mm. Son looking for any suggestions.
Wayne

Interesting to note that the circle was to be 50 mm and was off by 3-4 mm. The square was to be double and the difference in sides was also double the circle error. Don’t know if that helps any.
Wayne

This whole thing has me baffled because the NEJE SW does produce a square. I would expect it to be off by the same error if it was HW. Maybe there’s some compensation setting in LightBurn that I’m not aware of, but it’s definitely time to call in the big guns. @Rick have you got any advice here?

You can post each software output, save the GCode for same job. Draw a 100mm x 100mm square and set the exact same in both, save and post for review here.

GCode! Of course! Why didn’t I think of that? :thinking:
That’s why you get paid the big bucks!

Any chance you have Enable Rotary “on”?
Usually when Y belts are loose, the oval is towards the X side, as in the Y motion gets smaller not larger
The only way i can imagine it happening is having Rotary enabled option, which alters Y steps on the fly

Yes I did. I am so sorry for the mistake. Rerunning the file and everything is Hunkie Dorie.
Thank you for the wonderful support and sorry for the mistake.

I keep doing that all the time ence why i thought of it :slight_smile: