Click-to-Position only working on X axis

as the subject title already states. I have the problem that the Click-to-Position function (or the Arrange -> “Move Laser to Selection” menu items) only positions the laser on the X but not on the Y axis. Starting from the home position, for example, moves the laser only on “it’s baseline” but does not move into the field, so to speak.

Here some info about my setup:
LightBurn 0.9.20 (MacOS version)
Neje Master 2 Plus (GBRL 1.1f firmware)

I searched the forum but couldn’t find a similar problem. Is there some settings or something within the config files I have to adjust?

Here are my machine settings (lbset):
Neje Master 2 Plus - 30W.lbset (5.4 KB)

I’ve tried Arrange->Move To Selection (a couple of variants) and also Move to click on target and they all work.
To debug, I suggest that you open the Console Tab, select “Show All” and then try one of your moves. You should see something like:
Note the “Y” entries on the G1 commands. If they are there, but your Laser isn’t moving, then I think you need to contact NEJE or try to reload your firmware.

1 Like

Thank you with the tip for the Console and “Show all”. That brought me a step closer to a working Click-to-position function. However, only a step and not all the way. :neutral_face: I am even a bit more puzzled.

So, to recap, engraving stuff as well as using the arrows from the Move tab, I can reach any position with the laser head. Using the Click-to-position feature, the laser head only moves on the X but not on the Y axis. At least, so I thought. It turns out, it also moves on the Y axis - but only between 0 and 260mm. Any Y value above 260 results in Y=440 (my maximum value). Here is the console output while using the Click-to-position function:

Starting stream
$J=G21 G90 X178 Y236 F6000
Stream completed in 0:00

Starting stream
$J=G21 G90 X179 Y251 F6000
Stream completed in 0:00

Starting stream
$J=G21 G90 X179 Y440 F6000
Stream completed in 0:00

Starting stream
$J=G21 G90 X180 Y440 F6000
Stream completed in 0:00

For the last two, I roughly clicked at Y=270 and Y=300. Mind you again, using the arrows from the Move tab positions the laser head on any Y value. Interestingly, the Move-to-position functions also only works up to Y=260.

It seems, I have something wrong in my settings. Can you point me to the settings (or config file part) which specifies the movement area for those two functions?

In your firmware, what are the travel limits set to? ($130 and $131). What is the machine size in LightBurn set to? It won’t jog outside of that.

1 Like

We need to look at your GRBL settings. Go to the console, type $$ and hit enter, then right mouse click on the window and click Select All. Then paste that result here.

I’m guessing that you haven’t set up your Laser properly. I suggest that you go to:

To get the proper configuration file ( neje_grbl_uploader_v3.2.exe ) for your system.

Run the uploader (with LightBurn closed) and then start LightBurn. It should now address your entire field. The movement may be slower than you’re used to, for some reason they have really bogus Max Rates in that file (500mm/min) . You can fix that, but the first thing is to get your system configured properly. You may need to create a new device in LightBurn so that it reads the latest settings from your laser. I don’t have enough experience with this to know the complete recovery procedure.

1 Like

Here is my output from $$ in the Console. $130 & $131 seem to be correct. Also the two places in the GUI where the machine size is shown match the real values (see screenshots).


@TomWs: That is what I have done initially but I will go ahead and try it again. Have to get my Windows machine first though.

The funny thing is that besides the Click/Move-to-position function, the whole working area of the laser is used (expect the hardware limitation between Y=0-20). So, Lightburn does work with the full range. Only this specific function does not.

Ok, I reloaded the firmware and tried it again (without altering any settings). Besides the very slow speed (as you mentioned), I am experiencing the same odd behavior. I have to correct myself, however. The highest working y value is not 260 but 255. This coincidently matches my maximum X value. Is it possible that those two values get mixed up somewhere?

Is it possible that you’ve connected the motors incorrectly? You might have X wired to the Y motor output and vice versa. That’s about the only thing that comes to mind.

I will check but wouldn’t in that case the normal engraving also show issues/problems (witch it doesn’t)?

It depends - are you saying you can engrave out past the size that click-to-move isn’t allowing?

Try typing $# in the console and press enter. Make sure the first line (G54) is all zeros. If it’s not, type:

G10 L2 P1 X0 Y0 to reset it.

1 Like

Yes, I can use the whole working are for engraving. Even at Y positions >255. No problem there. Also moving the laser head around with the arrow buttons works (but as I understand from the console output, the arrow buttons do not specify an absolute position but a relative on).

Here is the output from $#


Should I do the reset anyways or might I break something?

I made a video to show you the issue. First, I use the Move-to-position (250 & 255 work, 256 goes directly to 440). Then I use the Click-to-position function with the same result. In order to show that everything else works as expected, I placed a text at Y > 255 and use the Frame function.

Here is the link to the MP4 video on Dropbox:

PS: Don’t mind the disconnected laser. Just a safety precaution.

Can you do that same test, but turn on debug logging first? In the Help menu at the bottom, enable Debug logging. When you’re done, turn it back off, and you’ll find a file in your Documents folder called LightBurnLog.txt. Post that here.

You could also try just running these commands on the console:

G0 Y20 X255

followed by

G0 Y20 X256

If the second command moves really far from the first, I would guess it’s the firmware itself that’s at fault somehow. I’ve never seen anything like this.

1 Like

Attached is the log file. First, I used the move-to-position function (Y=255 & Y=256) and afterwards I run the commands on the console. Move-to-position, again, moved the laser at Y=440 when Y>255. The console commands worked correctly (i.e., moved the laser to Y=256).

I recognized a very interesting thing in the console and it is also showing in the logs. When using the click-/move-to-position function, Y=440 is send to the laser’s mainboard for Y values above 255. For values below 256, the correct value is send to the mainboard. Maybe I can make another video tonight to show it to you.

LightBurnLog.txt (3.6 KB)

NOTE: I switched the X and Y in your console command, since the issue in my case occurs with the Y-coordinate.

AND NOTE 2: Thank you for your support so far!

Found and fixed, will be in the next release. Thank you for sticking with it. :slight_smile:

1 Like

Hey Oz, do you already have a release plan for the next version including the fix? In case you need a beta tester for the fix, let me know.

It’s tested and verified already. We have a couple of things being tested now that are relatively large structural changes, so we don’t want to rush this one, but it shouldn’t be too long.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.