Closing a file without renaming it


A very simple question that I have not been able to figure out yet. Whenever I open a file in Lightburn I have to eventually close it. When I do so I only get save or save as. Each one makes me rename the file. I would just like to be able to open the file and close it so that it keeps it’s previous file name.

Thank you,


As long as you don’t change the file, it just closes again when you open a new one. If you change the file and close it, you will be asked if you want to save the change. If you press yes, the changes will be added to the original file unless you say save as.

If you try to ‘Open’ or start a ‘New’ file, you should see a similar dialog box with the option to not resave.

I’m doing a bit of ‘reading between the lines’ here so forgive me if I’m barking up the wrong tree.

LightBurn works just like any other program. You can only ‘Open’ a file if it already exists (and by definition must therefore already have a name). If you make any changes to this file you will be prompted to save etc. (as per @Rick’s post above). If however you run LightBurn and start designing without opening an existing file, then when you close LB it will ask whether you want to save etc. As it doesn’t have a filename yet it will display the file ‘Save As’ dialogue so that you can give it a name.

Hopefully this helps but if not just let us know.

You can click on the name in the file list and it will take that name… you will be prompted with a query to over write it…



Thank you for all the suggestions. However, I am still having issues with having to rename things. I am on a Mac using 10.14.6 with 1.1.03 version of Lightburn, in case that makes a difference.


Please share the exact step-by-steps you are taking and the screenshots of what you are seeing, to assist us in ‘seeing’ what you are describing, and we can go from there. :slight_smile:

Hi everyone who have responded,

As for questions pertaining to opening and closing files. Just made a simple design for a test. I have a better grasp now but still have a couple of questions.

Opened Lightburn by clicking Lightburn icon on desktop > Drew out design > Clicked Lightburn ( top left corner ) > Quit Lightburn > Prompt- Your project had been modified. Would you like to save before closing? > Save by naming in Save As text box > Save. Open that file at a later time and it is there, just like it should be. Now I modify the file and want to quit LB. Click in Lightburn in upper left corner > dropdown box > Quit LB > get prompt - Your project has been modified Would you like to save before closing? Options are Close, Save and No. Since I modified the file and want to keep those chages I click > Save. Now I have to name the file in the Save As text field, which already has a name. So I just type in the original name of the file and click save. Prompt tells me it already exists. Do you want to replace it. So I click on Replace. Next time I open that file it is there with the changes.

It took me awhile to figure this out, it is not like Photoshop, which just lets you save and the changes are saved. So I was a little confused. Question: Do you always have to name the file again and hit replace?

Thank you,


That’s odd, it certainly doesn’t do that on my Windows 10 systems. I’m sure it shouldn’t behave the way you’re describing. Perhaps someone with a Mac can confirm.

Thank you.

I am unable to reproduce this behavior using the current Mac release. Images below show further testing with a beta version yet to be released. Following your exact steps, when quitting, I am presented with the option to do the initial save which is not the ‘Save As’ as you are describing. I get a ‘Save Project’ dialog.

Then, reopening this same file and make edit(s) and select ‘Quit’ again and I’m presented with the following, which is different than you are saying you see. I do not get the option to ‘Close’

At this point, when I select the ‘Save’ button, LightBurn saves / overwrites the file without presenting further options and closes.

Please capture the screens you are seeing.


Thank you for your effort


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.