Closing shapes - can't see what I'm missing

Hi. I’m relatively new to Lightburn (love it by the way!) and have so far manage to nut out any issues except the one I’m facing now. Which is closing some shapes that to my eye looks closed but rather than being one vector is 37 open shapes. I’ve tried the Auto Join seleted shapes but nothing changes. I’ve also tried Close selected paths with tolerance - but even with a crazy 3mm tolerance, none of the shapes are closing (see attached screen grab). Any help or suggestions welcome. Thanks!

Did you try with ‘join with line’, instead of ‘move ends together’.?

We can’t tell much from what you have given us.

Can we view the .lbrn2 file…?

You can use the download-icon-lightburn or just drag and drop the .lbrn2 file on the reply window.


Thanks so much Jack. I tried the join with line with the same result. I’ve attached the file.
join-problem.lbrn2 (36.6 KB)

Just opened it. I can select ‘parts’ of your design. That’s clearly indicating they are separate.

Might help if you told us how you built it…

Do you know how to use the ‘node’ editor…?


Zooming in reveals that the ends of line segments are not joined. These are sufficiently far apart that there likely won’t be an automated way to join these, especially at this number. Was this imported from a DXF?

If so it’s possible if you set auto-close tolerance in DXF import settings to 0 that these will come in better aligned but not likely given what I’m seeing.

If this came from an illustration program then I suggest you export as SVG or AI format as that will avoid these issues entirely.

You can fix these by manually moving the end node of one segment to another node.

I did this with the node editor…

join-problem.lbrn2 (33.3 KB)

One of Lightburn videos on node editing. It’s an early release, but it shows the basics.

Good luck…


These are all great solutions - thank you all! Yes, it was imported from a .dxf - looks like node editing is a skill I need to learn! Thanks again. Greg.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.