CNC 3018 with GPRL Woodpecker controller does not connect


I have a small CNC 3018 pro with a woodpecker CAMXTOOL V3.4 controler, running under win 10, that does not connect to lightburn. Switching the com port to the right one from the menu lets the laser turn on for a moment but wouldn’t connect. The laser runs perfectly in ESTLCAM with every function. I usually use the machine as a cnc router with estlcam. Latest CH340 (CH341SER) driver is installed.

There’s no chance to have it connected. Also tried Laser GRBL 3.4. but also noch chance.

Thanks for helrp :slight_smile:

Do you know what baud rate the controller uses in Estlcam? It’s possible that it needs a different setting than the default. Do you see anything echoed in the console when you attempt to connect to it?

Hi, the controller uses 9600 Baud in Estlcam, I have used the same settings for lightburn.
When I change the port in lightburn and switch back to the correct port in lightburn, the laser turns on and off for a moment. The laser compartment/window also says „ready“ in the upper left corner, when I load a project I can also hit the start button but nothing will happen.

The console keeps saying „Waiting for response“ I haven‘t seen anything else yet … so it seems some part of the connection is not right

Hi, any further idea? Thanks

Have you set the same baud rate in Edit > Device Settings in LightBurn?

Yes, same setting …

Hi Oz, I have flashed the controller now everything runs just fine :slight_smile: Thanks for your help.

Very strange, but I’ll take it. Happy you’re up & running.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.