CNC shield and Arduino. everything installed but nothing good happens

Hello again to all of you who are so good at helping!

Already saying thank you!

Have now become a little warmer in the clothes and will start building CNC/Laser cutter no:2.
This time I want to use CNC shield and Arduino.

Have set the stepper motor sensors correctly according to the stepper motors I have.

I have followed all the steps and got as far as getting the CNC Shield up in LightBurn, showing my settings and the console’s $$ numbers.

But when I then, for example, I press the toggle “move x+” the motor just shakes a little, I’m trying to post a video of the process.

I’m not that good at coding and don’t know where to start troubleshooting!?

Do you have any ideas, maybe cod I can drop into the console to make it work!?

Thank you so much for your thoughts and ideas!

Best regards, Petter

well, you’ve got an unusual grbl setting for $30.
Please change that to 1000 so it matches S-value max in device settings.

you can enter that directly in the console window:
then press enter.
you can repeat the $$ report to confirm the setting change.

When you say, stepper motor sensors are these ‘feedback motors’ or are these limit switches / end stop switches?

Which stepper motors and driver chips have you selected for your build?

DRV8825 and HANPOSE 17HS6401S-PG Nema 17

I tried the change at position 30, but no big difference
and in the picture you see the small screw you set V ??

Looking up your stepper motors it looks like they’re rated for 1.7A If I recall correctly it’s 2x Vref for drv8825. I’d probably try for .85V but you should look it up to verify rather than take my word. :slight_smile:

that is correct, its sett to 0.85

Vref setting for stepper current. great - no issues there.

Change the units in LightBurn to mm/minute (instead of mm/s)

Please capture the Move window contents. I’m wondering if the units are responsible for an over-speed request. :slight_smile:

Nothing seems to stand out in your settings the best I can tell. Maybe post a video of exactly what the problem is would be helpful. Only thing I can think of is what do you have the micro stepping set at? Maybe the jog speed your trying is to high for your stepping at 5994 mm/m, might try lower to see if it helps.

Sorry John John but I don’t know how to get a video into the chat

and is this what you mean by “Change the units in LightBurn to mm/minute (instead of mm/s)” if you look at the picture??

1 Like

something happens, instead of vibrating it ticks like a clock, i.e. back and forth in the same place
But it does not move “1” step forward

I tried with 1000, 100 and 10

Could it be the a1-a2 and b1-b2 connections are not wired correctly on the stepper.

1 Like

I’m a bit confused, shouldn’t you connect two and then it will be “slower” to turn, it doesn’t seem to work, do you have a diagram for how it should be connected? only have the standard cords that came with the Nema 17 motors, I’ll look on youtube too!

checked and it works but is it connected correctly for the card??

If the red & green circles are meant to identify coils then I would say it’s wrong on the board side. If the red & black wires are coil A and the green & blue wires are coil B they should be side by side on the board side I believe.

Question! Could it have something to do with the fact that I had/have a Neje laser machine already connected to lightburn? i.e. if it is in the way, somehow even though I have “read” the new board ie Arduino /CNC shield

interesting! will change and reconnect!

Verify before you do. As I’m looking at my drv8825 driver board the pins don’t match the image I posted.

ETA: Looking at it upside down it actually does match with the pcb layout.

It works!!

it was the contacts that were connected incorrectly!

I am eternally grateful!

I’ll probably come back with other problems in the future!

Thousand thanks! greets Petter

1 Like

Great glad it’s working for you now.

Good catch Gatlin63 (Rudy).