CNC xPRO V4 Controller

I am in the process of building an OpenBuilds ACRO machine with this controller. Are there any tricks or tips you have to offer as to hardware/lightburn setup?

1 Like

Does the Xpro run GRBL? If so, make sure that you set $32=1 to put it into laser mode, or you will have issues with the laser not turning off between moves.

It is suppose to have GRBL 1.1 pre installed. Board arrives tomorrow. Just trying to have all my ducks in a row before I start building.
Open Builds supplies a bunch of suggested start up settings. $32=1 is on the list

Make sure that it is GRBL 1.1f and not 1.1e. E had some bugs that cause it to misbehave with lasers occasionaly.

Thanks for that.
I am not sure what version is on it.
Ughh… one more thing to do.

1 Like

1.1e or earlier do work, they just don’t ramp power up and down as the velocity changes. If you’re doing image engraving with overscan enabled, or just cutting, it’s not likely to matter. If you’re trying to do vector marking, then the velocity control is more important.

Everything (minus the laser) showed up today.
LightBurn did not like my old Acer laptop, but fired right up on my Dell.
95% mechanically assembled, but still have to wire everything.
Where in lightburn do I go to put in all the GRBL settings that Openbuild recommends to use?
It does connect to the control board GRBL version 1.1f

Disregard, figured out how to load them into the console.

You can also use the Edit -> Machine Settings window for a nicer interface.

1 Like

I know this is not rocket science.
Built the Openbuilds ACRO system.
There is no build instructions for wiring this thing.
I hooked up my X motor (have to swap the wires runs backwards. But the limit switch does not stop the motor. I get a RED led on the board indicating that it reads the switch as being hit, but the motor keeps running. This is when I try to jog the motor with lightburn.

Look here at the “Hard Limits” setting ($21):

LightBurn exposes the bits as individual axis settings in Edit -> Machine Settings, so it’ll be a bit easier to edit them there, but it’s just a view on these settings.

Soft Limits are also useful ($20). Once homed, the machine knows how large it is by the Max Travel settings ($130 & $131) and won’t go farther than those, slowing down before it ever hits a limit switch.

I had found that page. Thank you.
I have the home of machine set at front left, I also have X & Y limit switches at the home position.
(No Z axis)
I have limit switches for the far points but have not installed them yet.
Physically my machine is 1000mmX1000mm, but I put in soft limits of 900X900mm ( figured out how to adjust them in LB)
I would think the jog function in LB would stop the motor once the limit switch was set, but I have NOT performed a homing function yet. I think that is what is missing?
I am trying to just get the X axis going only one motor to contend with. Figured once I get that figured out, the rest would be easy.

1 Like

Got the X axis motor running correctly.
I think I am not understanding the homing part. I have my switch wired NO normally open. Should they be Normally closed?
Should the homing cycle $22 be set to 1 or 0?

1 is on, 0 is off for the parameters.

Homing Cycle should be 1 to enable it. You can also use the Edit -> Machine Settings window to get a more user friendly way of setting these.

1 Like

Got her going.
Had to load an Openbuild GRBL firmware version 1.1g.
Flashed the new firmware, homes just like you said it should.
If a home/limit switch is activated when powered up it gives me an Alarm. Ask me to input $H|$X to reset, but LB will not let me input any further GRBL commands at this point.
WHere is the reset button in LB?

If you have “Home on Startup” enabled in the device setup, LightBurn should do that for you.

You can try right clicking on the device button in the laser window. That will reset the device.

Where did you find grbl 1.1g? I thought f was the highest revision.

It is a special release just for the Openbuilds controller board version 4.
When I was using the openbuilds GRBL it asked me to upgrade to it.

I’ll double check that setting.
I know when I first tried it. Y axis was NOT at home, X was against the switch. gave me the error.
I will give it a try.
Have to send Openbuilds an email, their wiring diagram for the version 4 controller board is incorrect.
It shows both Y axis motors wired the same, this is incorrect, you still have to reverse the wiring on the 2nd Y axis motor.
Are you saying I should select C3D GRBL?
I just selected GRBL