Co-ordinates isssue

Hi all, newbie here,
I downloaded the trial Lightburn software and it connected fine to my machine with Trocen TL-3120 controller. The main issue I have is with the co-ordinates. In the drop down box there is no option for absolute co-ordinates only “controller setting”. I have been through all of the menus in the TL-3120 controller and can find nothing to change that makes any difference, the job origin is always part of the drawing which is not where I need it.
First impressions of the software are very good but this could be a deal breaker unfortunately.
Any suggestions?

Here are a few tidbits from other posts discussing this subject.

“Trocen has never supported the ability to change the origin settings from software, so you need to change the settings on the controller itself. Having the other settings present was a support headache because they didn’t work. It sounds like one of the options was giving you a behavior you wanted, but it wasn’t intentional.”

You leave LightBurn in “User Origin” mode. On the controller, press Menu, then choose Common Parameters Settings, then Work Mode, then Origin Mode. Once you’ve changed the origin mode on the controller itself, it will work.

Search the forum as you will find a bunch of discussion and information that will help you better understand how the Trocen controller origin is set and used.

Hi Rick,
Thanks for the reply.
I had searched the forum for "Trocen origin " and read all I could find.
I have been through all of the menus found the Common parameters, Work Mode, and Origin Mode, tried all the different settings ( Machine origin, soft origin, key origin etc ) and none of them seem to make any difference.
Whatever I draw, or import has the green dot at the corner of the drawing and not at the machine origin.
So when I ask the machine to frame it assumes the laser is at the position of the green dot and frames accordingly ( near the home position ) regardless of where the drawing is in the work space.
Im trying to think of a work around but Im struggling.
Ive just realised I have the same issue in Lasercad, so maybe its just something I have to put up with.


The only way I’ve gotten my Trocen controller to work with absolute coordinates is to put the controller into soft origin mode and put the job origin in Lightburn at the top right corner. If the job origin is is on the left side, things go side ways. My machine’s home position is the top right corner of the bed.

I think this is an issue with framing, but is not an issue with actually running the job. I have to do some digging to see if there’s a way for me to retrieve the origin mode from the machine so I can adjust the frame accordingly. If you upload the file to the controller and frame from the controller the frame will be in the correct location.

Hi Isaac,
Thanks for that, it gets me a long way towards where I would like to be.
Before that, wherever I moved a job in the work space the machine always tried to cut it from the machine origin. At least now it goes to find the new position to cut the part.
What was confusing me is that I was on that ( soft config ) setting in the controller, but testing with the frame button in Lightburn and it didnt find the new position. As Oz has pointed out, In Lightburn I have to move the part, send it to the controller from Lightburn and once Ive framed form the controller ( Box button ) then Lightburn will frame correctly.
All is looking much better now.
The only minor issue is that once it has cut the part it doesn`t return to the home position but stays at the job origin ( green dot position ).
I can live with that.

Thanks everyone

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.