CO2 laser limit switch problem

I have this problem with my Y axis limit switch since yesterday. I used to laser to cut something, turned it off, and when i turned it back on a couple of hours later i noticed that the Y axis limit switch/proximity sensor is glowing even though the gantry is far away. When i tried to move the gantry up on the control panel, it wouldn’t move. I presumed the switch is faulty and i replaced it with a new one. But when i turned the laser on, the new limit switch was glowing also. The only difference was that this time i could move the gantry up on the control panel. When i press reset, the gantry goes home and bangs the Y limit switch and i have to press E stop to turn the machine off. The controller in question is RD6445G. Has anyone else experienced something like this? What could be causing this? Please help.

I think those are hall effect, do you know? It’s a very simple system. Generally when the device seeks on power up, it watches the line going to the limit switch. When that line goes low, it know the limit has been reached. It then jogs a little bit away, moves in again more slowly, for the best accuracy, until it goes low again and then it determines that as the limit. It backs up a little to be ‘off’ the switch.

You should be able to check these with a voltmeter. You know the X switch is working so you can measure it and compare to the Y switch. Most of these are configured to go ‘low’ indicating contact. If you sensor is glowing it could be as simple as another bad ‘new’ switch. The other option would be another circuit on that input (unlikely) or the controller input circuits could be pulling the line low.

If the light is on, I’m guessing the machine doesn’t seek or runs into the Y switch end. I have a 6442, but my grbl controllers wouldn’t do anything, but complain, if one of the limit switches were active when I attempted a homing cycle. Never tried to push my 6442 gantries into the limits to see if it choked on power up…

Can you supply a link to the replacement switch? I’ll look at it and see what I can think of… Indication that it’s being triggered is concerning.

You could try this, if your adventurous…

You could do a simple test… Swap the controller Y with the X limit switch at the controller. If the X switch lights when it shouldn’t, it would indicate a controller. You will have to be on top of it to ‘esc’ out before a crash, but you probably do anyway on power up.

Anytime you touch something ‘under the hood’ you take a chance of breaking something.

Unfortunately i do not own a voltmeter… I guess i should get one. The replacement switch was supplied with the machine, it is the same type as the one that was installed. I made sure i swapped it correctly.

The controller has led lamps on it which indicate if something is triggered, or working or whatever. The x axis lamp lights on when the switch is triggered. The y axis doesn’t. I’m thinking if i should try the swap test you suggested, but i’m afraid i could break something even more…

If you wish to fix this yourself, you will have to take the chance you will break it. The only other option is to pay someone the money to know how to fix it and can make it work if they break it.
Most of the time if you take precautions and understand what you are doing, you will be fine.

I went back and re-read the original post:

It sounds like the first sensor was stuck ‘on’. Maybe the second is stuck ‘off’ even though the LED is illuminated…

The new switch is not telling the controller that it’s triggered. The switch shouldn’t ‘glow’ until triggered. Continuously ‘on’ is a problem, especially since that’s not the signal that’s getting to the controller.

In the original failure, the limit switch was on (according to the LED on the switch). Too bad you didn’t look at the control board. It doesn’t explain why a new switch would have, 1) same continuous led and 2) different operation from the control panel.

The LEDs should tell you what you need to know. It’s pretty clear that the signal is not getting to the controller or the LED would illuminate when it was reached.

Had to go power up my machine and see what it did. –

On power up LEDs 1 and 3 illuminate when the switch is active. I think it was LmtZ- and LmtY-

I would double check that you wired up the switch properly. Looks like the typical digital inductive proximity sensor. Usually have a B+, ground and signal. I don’t know how you could have it connected incorrectly since the LED (I’m assuming an led) is illuminating.
Most of these are configured ‘NO’ (normally open) so when they are contacted, they ‘close’ or pull the line to ground level. Check that the replacement is placarded as a ‘NO’ switch.

Put a voltmeter on you wish list anyway, you will use one.

Good luck :slight_smile:

— Just went out and pushed the axes so that the switches are ‘on’ when it’s powered up. It takes the controller a few seconds more to figure out it’s on the senors. It backs off them then does a standard power up home routine. So the Ruida does not fault when this condition occurs, like my grbl controller does. Hopefully this helps sort it out… :slight_smile:

I just managed to solve it. The first sensor was indeed broken, and the second one was connected properly. And the only reason the second one didn’t work, was because i mounted it a fraction of a milimeter too high, and the gantry was hitting it before it was activating it. Stupid me. Thank you very much for your kind help Jack, and sorry if i wasted your time. :slight_smile:

No perspiration. Don’t let it keep you up at night. Sometimes it’s nice to have someone to bounce stuff off of…

Take care. :slight_smile:

1 Like