CO2 laser will not connect

Hello,

I am working with a Chinese blue and white CO2 laser, that is running a “zye laser MYJG40W” laser. I have multiple other diode lasers that run fine with lightburn but I can not get this CO2 laser to connect. The computer recognizes the laser because I can see it under devices, and it chimes when the laser is plugged in. So, I am confident it is not the usb cord. When you click find my laser it doesn’t recognize it, so I created in manually. I created it as GRBL and that didnt work. I even tried connecting it as a Ruida and that didn’t work. Like I said I have multiple diode lasers that run, but this CO2 laser is a pain. Console just says “waiting for connection”

Any ideas???

Thanks in advance.

Hi Lauren, when you first set up the co2 laser did you select ‘load the FTDI’ driver?
If not just do the setup again and when it shows the ‘FTDI’ select it and that may be your problem solved :crossed_fingers:

What OS are you running? What version of LightBurn? What motion control system drives this “zye laser MYJG40W”? If you don’t know, share a picture of the HMI control keyboard panel on the front of the machine, and we may be able to help answer that.

Start with this and we can go from there. :wink: