Comgo Z1 bricked after reflashing

I have a Comgrow comgo Z1 10W laser engraver. It was working great with LightBurn but would not connect to LaserGRBL so I contacted the manufacturer and they suggested I “refresh” (reflash) the firmware. I did so, but now it won’t connect to LaserGRBL OR LightBurn. When I manually recreate the device and connect it, LightBurn says that it’s connected. I turn on “All messages” and the device keeps repeating the G0 signal and will not accept any commands including the $E reset command. (maybe manufacturer-specific)

I know the device works so I am reluctant to return it, can anyone please suggest something that I can do to resolve the issue?

I don’t even care about connecting it to LaserGRBL at this point because I already purchased LightBurn and it was working perfectly.

I don’t know what modifications were made to the firmware, but if anyone is interested in reversing it, I can provide the firmware file.

Have you reconnected with the manufacturer for support? If they instructed you to flash the firmware and it bricked the device then they should help you debrick it.

Have you tried reflashing the device? Or reverting to an older firmware?

Depending on the state of the device there may be a way of recovering but that will be machine specific.

Yes I have been trying to communicate with them, but they are in China and seem to only read my last email, and only reply once per day. Ugh… When they provided me with the firmware, there was only the firmware.bin file and a video tutorial on how to image it. The process is to copy firmware.bin to a micro SD card and turn on the machine for 20 seconds. I have done this multiple times and have downloaded the file a few times in case it was damaged in the first download. I would love to return to the previous version because it worked great with LightBurn which I now own. I’m at the point where if they can’t fix it for me tonight I will return it to Amazon for an exchange. (They are half of a day ahead of us and it will be their Friday). I have considered trying to get them to chat with me, but I don’t know if there is a live Google translate service online.

The other awesome thing is that they have included an ESP8266 module to enable WiFi with absolutely no mention of it in the manual or any documentation that I can manage to find for the device on the internet. So no way of knowing how to connect to it. I even found documentation for the same module in LaserGRBL docs, but the address does not work, at least in my devices current state… Frustrating to say the least, but the thing works well when it works and it’s pretty powerful and precise.

Are you absolutely certain you are connecting to the right port? With a new firmware it’s possible that a new port was created.

Not sure what you mean, but I’ve uninstalled the driver and reinstalled it. I’ve also tried all three of the usb ports in my PC.

LightBurn communicates to the laser controller via a USB Serial connection. Serial connections in Windows are assigned a Port that will look something like COM2, COM3, etc.

Check your Device Manager for all ports. Make sure that one is available and that you are using the “correct” port.

Can you take a full screenshot of LightBurn while connected to the laser?

Yes, I have tried this. I have three, each assigned to my 3 USB ports COM3, COM4, Com5. Each is only shown while the engraver is plugged in.

Does the laser have any sign of life? Flashing lights or anything like that? If so, do the lights change after some time?

Also, do you have any serial communications program installed on your computer?

Yes, it sometimes flashes on when powering it up.
I do not have any serial communication program installed, are there any that you would suggest?

Portmon used to be the goto monitor but apparently it doesn’t support 64-bit.

I found this but haven’t used it. Might be worth monitoring the port to see what’s happening when you turn on the laser and when you try to connect with LB.

Release v1.0.5988.23754 · whitestone-no/open-serial-port-monitor · GitHub

As for the wifi module i asked and was given the place to install it. the module plugs into an 8 pin block near the center of the circuit board inside the z1. problem is the markings are on the back of the board so you have to remove the main board to figure it out. however, if you want to trust me the board goes in with the antenna toward the center of the board. it will go in the opposite way. to be positive just take the board out and read the markings for the 3v3 markings etc. I installed it and the laser worked, not sure how to utilize the wifi module yet. they didn’t send instructions via facebook. user name was flora ye on facebook from comgrow user group.

One more thing i had to do to get mine to recognize it was to install the HL-340 driver for windows to see mine on the correct usb port.

I’m not certain but I suspect you could connect to it with laserGRBL using their ESP8266 connection protocol.

See here for more information:
WiFi with ESP8266 – LaserGRBL

1 Like

I have already returned it for an exchange. I should be getting it in a couple of days. This time, assuming it connects to LightBurn, I plan to simply leave it. No software “updates” for me. someone from Comgrow has also told me that they were sending me a replacement motherboard. I have a tracking number, but no activity. I’ve heard that this is the way they handle defective products, which is why I insisted on Amazon. (At least they back the purchase)

I have a congrow z1. once I got the wifi module installed. I was able to connect via wifi to the module. However I could not bring up a page to set up the wifi for the module. Suppose to put to connect to it but I don’t get anything in the browser.

Is it possibly acting as its own Access Point that you need to connect your wifi to? Try searching for new wifi connections.

I thought the same thing, but it isn’t running a DHCP server. I tried assigning my laptop adapter a static IP of (and a few others), then tried connecting to, but still no go. I think that it’s specifically intended for connecting to the device via a smartphone or tablet running Android (or iOS). Anyhow, I ended up getting the device replaced through Amazon and I haven’t tried connecting the WiFi adapter because I have no need to connect to it from my phone and I don’t want to do anything else that could break it. I do however have a backup mainboard for the device, so I may mess around with the spare.

According to @eddie120678 the default IP is supposed to be so perhaps just a matter of matching subnet.

Mobile app wouldn’t be that interesting to me but connecting from laserGRBL potentially would be if that was a possibility.

Try setting a static IP address on your wireless network adapter to , subnet mask of , and default gateway of