Comgrow Z1 laser stops randomly

My laser machine started stopping randomly during cuts. It stops dead in its tracks and the laser turns off. Sometimes I can hit pause, and then restart and it will pick up right where it left off. Other times it will not. I will be forced to hit the stop button, send it home, and start the program over. Sometimes I can run the same program and it will run all the way through. It is definitely stopping at random different spots. I plan to re-flash the firmware and re install drivers restart my computer and try again.

Comgrow Z1?

Can you take a close picture of the circuit board?
I’d like to know if it’s an ESP32 device.

One user had success with something unanticipated. The DTR software setting.

A lower baud rate may reduce data loss if you’re in an electrically noisy environment or if a weak cable is involved.
The baud rate and DTR information may be worth review:
https://lightburnsoftware.github.io/NewDocs/DeviceSettings.html

Has there been solution to the random shutdowns noted.

My particular setup: using Lightburn w/ current update on a Macbook Pro with ver. 10.13.6.

I’ve noted and tried the solution suggested noted. Again the shutdowns are random and do not occur with every job.

Appreciate your help in this matter.
JNM

2 posts were split to a new topic: xTool D1 starts then almost immediately stops

This is great diagnostic input.

Three things we’ve seen reported multiple times are common causes for this.

Static electricity, weak USB cables, and RF noise / interference are the usual suspects.

Are there any messages in the Console window when the stop happens?

I’ve recently starting having this exact issue as well. Shutdowns are random and do not occur with every job. Before enabling DRT the pause/resume would intermittently work after the job stopped. Enabling the DTR settings seems to allow the pause/resume to keep working. I have swapped USB cables, the new one has a single RF choke, I have more chokes on order to see if one on each end helps. Happens in both 1.2.00 and 1.2.01. How would one deal with static issues?

Just saved the project as gcode from Lightburn and tried burning it in LaserGRBL. About seven minutes into the burn it paused again, and the status listed is “Cooling”, at which point even after several minutes, it never resumes.