Comgrow Z1 laser stops randomly

My laser machine started stopping randomly during cuts. It stops dead in its tracks and the laser turns off. Sometimes I can hit pause, and then restart and it will pick up right where it left off. Other times it will not. I will be forced to hit the stop button, send it home, and start the program over. Sometimes I can run the same program and it will run all the way through. It is definitely stopping at random different spots. I plan to re-flash the firmware and re install drivers restart my computer and try again.

Comgrow Z1?

Can you take a close picture of the circuit board?
I’d like to know if it’s an ESP32 device.

One user had success with something unanticipated. The DTR software setting.

A lower baud rate may reduce data loss if you’re in an electrically noisy environment or if a weak cable is involved.
The baud rate and DTR information may be worth review:

Has there been solution to the random shutdowns noted.

My particular setup: using Lightburn w/ current update on a Macbook Pro with ver. 10.13.6.

I’ve noted and tried the solution suggested noted. Again the shutdowns are random and do not occur with every job.

Appreciate your help in this matter.

2 posts were split to a new topic: xTool D1 starts then almost immediately stops

This is great diagnostic input.

Three things we’ve seen reported multiple times are common causes for this.

Static electricity, weak USB cables, and RF noise / interference are the usual suspects.

Are there any messages in the Console window when the stop happens?

I’ve recently starting having this exact issue as well. Shutdowns are random and do not occur with every job. Before enabling DRT the pause/resume would intermittently work after the job stopped. Enabling the DTR settings seems to allow the pause/resume to keep working. I have swapped USB cables, the new one has a single RF choke, I have more chokes on order to see if one on each end helps. Happens in both 1.2.00 and 1.2.01. How would one deal with static issues?

Just saved the project as gcode from Lightburn and tried burning it in LaserGRBL. About seven minutes into the burn it paused again, and the status listed is “Cooling”, at which point even after several minutes, it never resumes.

i had this issue too.
in LB, go to console. type in: $33=0
you only need to do it once. never need to do it again

This is very interesting. In some GRBL variants $33 is the PWM frequency and in others it’s spindle fault monitoring. If it’s a high temp shut-down feature I wouldn’t recommend setting it to zero. I will dig into the comgrow docs and see if it’s fault monitoring and attempt to confirm what it’s looking for.

[edit] - of possible interest, Q8 in the Comgo Z1 User Manual V1.1 suggests adjusting the $140 parameter when faced with random stops.

[edit] - Just found the $140 and $33 references on the last page (17) of the Comgro Z1 “LightBurn User Manual V1.1” that was on the tf card that shipped with the laser.