Comgrow Z1 no longer connects

good day. A couple of days ago I bought a Comgrow Z1 machine, which I performed tests and turned off, everything was very normal; but the next day I find this same surprise that it does not connect to the PC. I have tried disconnecting and reconnecting the parts, updating the firmware… all with no results. I do not know what to do. I’m going to try changing the board for an Arduino to save the parts.

Before you continue, it’ll be a good idea to connect everything back up and start from the beginning. Does your laser power on & show power to any LEDs or audibly energizes & locks the stepper motors? Do you see or hear anything when you connect the laser to your computer through USB in your device manager? What’s displayed in the LightBurn Console?

Good day.

The machine turns on normally, including LEDs and the laser module diffuser. In the device manager you connect and the assigned COM appears. I have tried changing the baud on the computer and software equally without results. I have also checked wiring and connections, everything is ok.

It keeps showing that it is waiting for the connection…

It looks like you’re connecting on the right port (com 4), and with the right driver (ch340), and at the right connection speed (115200).

Some additional items to check:

  • Activate the “Enable DTR signal” toggle in LightBurn in Device Settings → Basic Settings → Other Options, disconnect & power cycle the laser and attempt to connect again
  • Change the bits per second to 921600, restart everything and attempt to connect again
  • Is there a green LED flash when connected through USB?
  • Plug the laser into a USB hub and then the computer running LightBurn
  • Consider installing the CH341 driver as well/instead, restart everything and attempt to connect again

Initial search results suggest a potential vendor-based hardware solution if the problem persists.