"Complete Inner Shape First" Doesn't Work For Text Scoring?

Hello, I am attempting to ‘score’ rather than engrave text. My issue is when Lightburn decides to complete the inner part of letters such as “A” at a different point than the outer letter. I understand my machine likely needs to be calibrated, but the letters look perfect when completed at the same time (inner part first then outer part). I can watch some letters be completed at the same time whereas others are done in pieces. I will work on calibrating my machine but currently is there anyway to ensure each inner piece of letters (A, B, R) are completed at the same time as the outer bit of each letter? I have included my optimization setting.

Can you attach your file (or email it to support@lightburnsoftware.com with a link to this thread)?

It should work as you expect, however:

  • you haven’t said which version you’re using (a number of bugs with path ordering were fixed in 1.2.04, but there may still be some)

  • I can’t tell if those shapes are properly closed, and if they aren’t, inner/outer sorting won’t work

  • I can’t see your layer settings, and if you’re using multiple sub-layers, inner/outer sorting won’t happen on anything but the last line pass because the system knows that’s the only one that could be a cutout, and therefore the only one for which that order is important.

Fundamentally, your laser appears to be slipping or losing position. Scoring is much more likely to do this than filling because the motion is more complex. Slowing down might help, or reducing the acceleration of your machine.

Thank you for your quick reply.

I had the option to download 1.2.04 I believe but just kept forgetting to, and then my license for updates expired I believe. I am currently using 1.2.00

The paths are closed properly, it seems.

I am scoring all the text as one layer, cutting the inner portions as a separate layer, and then the very outer line of the ornament as a final layer. I am not utilizing the sub-layer feature currently.

I will work on the slipping, but I was hoping perhaps there is some way to control Lightburn to complete the inner parts first - even with scoring. I have the power the lowest I can and the speed quite low but dealing with the veneer on the ornament flaking away on some inner parts, so slowing down even more will cause those parts to fall out easier. So right now I am hoping to help the slipping problem, hoping to complete inner parts first. I have sent you an email with the file attached for you to take a look.

If your license expired after 1.2.04 was released it doesn’t matter - you would still be able to use it. I can almost guarantee that’s the issue.

I tried to look up your key from your email address to verify, but I can’t find it from that.

I have updated to 1.2.04 but I find that it is doing the same thing - doing this inner portion of a B and then leaving to do another section, then back.

Do I need to create a new file completely? Perhaps opening the same file that I was using is causing this still to happen, or it is just something not controllable with Lightburn currently?

You have ‘Hide Backlash’ enabled, and that’s going to push things in some weird directions sometimes because of the way it works. Try with that option (Optimization Setting) turned off and see if it’s more predictable.

I have marked this as the solution because it does appear (at least in the preview) that the letters are now being completed literally perfectly in a circle. With ‘Hide Backlash’ on, the letters are completely random.

Now to get onto getting my machine properly calibrated so I don’t NEED the hide backlash feature - it is very nice.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.