Conflict with Ikier 36w touchscreen controller

I have a 36w. My touch screen controller is in conflict with my physical configuration. I have the extender rails added but on page “3” of the menu it doesn’t recognize the extension and if I try to set up a job through Lightburn that is outside of the 410 x 410 parameter my laser does not function properly at all and flies off to a hard stop and will not set Auto focus correctly. I have no way to change that that I know of and if I want to use the extended area I have to unplug the touch screen controller to get it to work properly. Is there a way to change the setting on page three to reflect a 410 x 750 configuration?

Hi Kenny,

We don’t have any Ikier machines on hand internally here - however it sounds like the first step is going to be tracking down the documentation for that extension and ensuring the firmware on your laser is correctly configured for that extension. Then, extending the workspace in LightBurn’s Devices menu isn’t too hard after.

After some searching I found this on AtomStack’s support site - it looks like they just want you to change the firmware through GRBL’s terminal interface rather than providing a new firmware.

Was there any guidance that came with the machine on how to adjust $131 with the console for the extension kit? You can do this in LightBurn by selecting the Console tab, then entering $131. You’ll likely see a response of $131=400 as your initial value - meaning the Y axis is set to 400mm long.

You can overwrite this to be 750 (which appears to be the K1 size seen here) with:

$131=750

followed by Enter

Thanks Colin. I’ll see what it does. There’s no documentation with the extenders and I couldn’t find a firmware update. I did email them and am waiting for a response but wanted to see if anyone here has had that issue. Much appreciated.

Remark: There is a a new firmware for the Ikier K1
1.449, dated 10th of July.
It can be found on the end of the user manual page: User Manual – iKier

However, it´s not related to the extension due this is covered by parameter as descreibed by ColinW above

1 Like

Follow up. The $131=750 seems to be doing the trick but it looks like I have to enter that every time i bring Lightburn up. Will let you know how it goes with Ikier after we go back and forth. I still think a firmware file link should be included with the extender rails so that doesn’t have to be done.

That would be the ideal situation.
The firmware upgrade instructions are in the User Manual.

To see if the firmware in the Ikier 36W would most likely benefit from a Firmware update please request these two reports from the laser engraver by typing the following into the LightBurn Console window.
$i
$$
pressing enter after each one.

The $i (dollar i) report offers us system information and it should show us the firmware revision number.

The $$ (dollar dollar) report gives us all the machine settings. It will be helpful to have a record of these here that you can come back to.

1 Like

@kennyraisin

Just following up to see if you got the rails extended and the settings change or firmware change completed. How’s it going?

Colin’s solution for entering $131=750 works. It’s a pain I have to enter every time I start it up. Not sure if IKIER will come up with a firm aware fix to enable changes to the controller.

1 Like

If the issues with the extended axis don’t come up until you send a job you could add the $131=750 to your “Start G-Code” in Device Settings. This will add that parameter to the Header of all your programs from that Device.

I did that but doesn’t seem to make a difference.&

I think it would work as a macro… a couple buttons to click…

:smile_cat:

Yea that’s a great idea

hey i had the same thing going on.
1- go to the top and hit the edit
2- go to machine settings
3- go down hit the tap that say OUTPUTS SETUP
4- look for X Max Travel (mm) ($130) This Should Be 410.000 unless you wanna switch it to another size
5- look for Y Max Travel (mm) ($131) here is where you put 750.000 once you just click ok and it will save it so you dont have to do this everytime hope this help

1 Like

Sometimes the settings are locked, sometimes they are changeable but are reset to factory values when powered off and on and sometimes they are allowed to persist through a power cycle.

The persistence of Machine Settings is generally a build-time option selected by manufacturers. So, either people missed the OK button (which happens occasionally), there was a Firmware change ( the manufacturer made a change), or your Ikier is remaining powered and not shutting off. Some USB cables power the chip where the Settings are held,

There are three pieces of information that would be very helpful.

  1. The Firmware version information sent by your Ikier K1 Pro. The engraver sends this in the Welcome Message when it connects. I’m hopeful that the manufacturer has made a change. You can easily select and copy the text from the Console window and paste it into a reply here.

  2. Confirm your $131 is currently equal to 750mm

  3. Unplug both the USB cable and the power cord from the controller and let the controller rest for 5 or 10 seconds. Plug it back in, reconnect to LightBurn and confirm that $131 = 750 mm persisted.