Connecting Ruida through Wifi


I just moved to a new home shop where the laser cutter is too far from my PC and routing a USB or Ethernet cable is almost impossible. I have been reading about ways to connect to my cutter wirelessly. Found the Lightburn Bridge but it’s sold out and I would ideally want to not spend any money if I don’t have to.

Has anyone had success configuring a router (I have a Netgear WNR2000v5) as a means to connect the laser to my home wifi? Is this even possible or should I look into buying a Pi with Lightburn Bridge and/or other options?


I tried to find a description of your laser, but was unable. If you are sure it’s a Ruida…

I used a t-link wireless router configured as a bridge. Ethernet to the Ruida until the Pi bridge came about.

The Lightburn Pi bridge software has the advantage of an addition software layer to handle the UDP that the Ruida uses… There is no error protocol for UDP… I had a pi laying around and just wrote the software to the card and it worked fine…

So yes you can use any Ethernet bridge to connect to the Ruida via Ethernet…

There is no usb support from either method that I know of.


Thank you Jack! I’ll give it a try before going through the Pi option.

When you had the router as a bridge, did it mostly work fine? How does this lack of error protocol manifest when using the setup in practical issues?

[edit]: I am sure it’s a Ruida :grin:

Ruida controllers are pretty well marked… ignore the black arrow…

The Ruida uses UDP, a subset of the tcp/ip protocol. This is a lower level protocol with no error control… I don’t thing the device even knows who it’s talking to.

I wish the Lightburn people would advise us of what they are doing in the Pi to help with data transfers… I do have less failures since the Pi.

The bridge worked well enough to not worry about the connection, so I’d suggest it over no Pi… I’d use sneaker net if needed, so it’s a step up from that :face_with_spiral_eyes:

Good luck


Hi Jack, and fellow forum users.

Just a quick update, I was able to connect to the laser through a range extender and managed to even make a couple of cuts, but its extremely unreliable. Pinging the laser using CMD times-out more often than not.

I am not sure if there’s anything to be done to improve this except buying a Pi and installing Lightburn Bridge on it.

It sounds more like you are not getting enough wifi signal to the bridge…

Ethernet is pretty stable and the only time the Ruida doesn’t want to answer is when it’s running a job… I wouldn’t expect any bridge to have the issues you describe, if it’s not a wifi issue.

I had good connectivity and rarely lost anything… before the Pi…


I did some further testing.

If I connect the Ethernet cable straight from the controller to the router I get no ping drops.
If I ping the repeater (wirelessly) directly, I get no ping drops, and they are fairly close, there shouldn’t be a weak signal.
It’s the combination of the controller going through the repeater that’s giving issues.

I’d think the only thing would be the Ethernet cable between the bridge and the Ruida…

If the Ruida is working via Ethernet and a working bridge is connecting via wifi OK … the only thing that I could see as a possible issue is the cable between the bridge and the Ruida… Otherwise it doesn’t seem to make sense to me …

Generally, Ethernet doesn’t ‘break’ or is intermittent … it usually works or it doesn’t. The only thing ‘flaky’ like that is wifi…

The Ruida use UDP, which has no error handling…


The cable is not the issue as it’s the same cable I used to connect the controller directly to the router and it worked flawlessly.

Some further tests… I plugged a laptop in place of the Ruida controller using the wifi repeater and no ping issues there. It’s the combination of the controller + repeater that’s giving issues.

So probably a last update from me, as the issue seems to be fixed. I ended up switching the TP-Link RE200 repeater I was using as a bridge for a cheap MSRM chinese one, and that did the trick.

Very strange, considering my router is TP-link as well, and the repeater was working well when connected to a laptop. It just seemed to not like the Ruida Controller for some reason.

Thanks for your help and insights Jack, I’m happy with my Laser Cutter working wirelessly now! I may consider getting a Pi in the future, but for the moment I’m up and running.



That’s all that really matters… happy lasing …