Connecting to CNC over USB with Mac M1 chip

I’ve read that there are issues with some USB connections with LightBurn for the Macs using the M1 or M2 chip. Usually I run LightBurn on my Mac, prep everything, then save the file and load it into UGS, running on a Raspberry Pi with a touchscreen, and run it that way.

I’m running into issues and wanted to load settings for my CNC into LightBurn to review them, but when I tried connecting with a USB cable, LightBurn did not seem to connect to my Shapeoko 3 CNC system.

Can anyone elaborate on the M1/USB/LightBurn issue? Is there an easy fix for that?

I’m considering creating a Linux VM on my Mac and seeing if the Linux VM can connect to the Shapeoko, but I know that, ultimately, the VM is running on my Mac and that the virtualization software (either VMWare or Virtual Box) will be depending on the M1 chip to do its work. Has anyone tried this and how did it work?

As far as I know the issues are isolated to Ruida controller and Mac. I don’t think this is an issue with other controller types from what I’ve seen.

Bottom line for Mac, if you can see the laser in System Report and a device is created and visible with ls /dev/*usb* then connectivity is generally not a problem.

Most Mac connectivity issues with non-Ruida controllers is due to missing drivers. Current MacOS versions should come with drivers for most common usb-serial chips.

1 Like

I run my Laser with LightBurn and M1Mac Minnie through USB. Haven’t had a problem. Before the M1’s came out I ran it with a 27" iMac


1 Like

I hooked up the USB cable and searched for the device. LightBurn found it and took all the needed settings from it. Then I deleted the older instance I had of the device, since I wasn’t sure if the settings were correct. It’s connecting fine now.

(Part of my issue is that the CNC device is in the middle of the floor, so I can use it for tiling when making larger signs or other projects. There is no way I’m running a USB cable over the floor, even with a cable runner to make it safer. And it’s too far to run a USB cable up through the ceiling, so I have a Pi to control the CNC. There are times (like now) that I wish I had a full time USB connection to my CNC.)

Ever thought of an Ethernet → USB adapter?

USB uses a differentiated data signal within the cable, so it should be not really be susceptible to noise.

I would guess that the Ruida is using USB 2 specifications. USB1 has a max speed of <15mb/s and USB 2 is around 500mb/s or just under. The Ruida talks at max of 100mb/s, if I recall from the manual. I don’t remember any type of usb that operates over about 5m in length and that’s based on the data rate.


Thanks, but that’s another rabbit hole!

I’ve had serious problems with lightning here, in the barn. (Some in the house, too, but not as bad.) I’ve lost devices connected to ethernet during storms. The cables in the ceiling are now fiber. Also the ones in the old waste trenches (2’x2’ concrete trenches in the ground floor). Since I replaced the ethernet cables with fiber in those areas, I haven’t been losing systems during storms.

I have been looking into USB over IP. There’s an open source project that does that and several commercial apps that do it. I haven’t had time to test it yet. (One concern with that is that once I set it up on a USB device, apparently it takes over, so I can’t still use that device locally.)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.