Connecting to F1 Ultra

I am trying to get Lightburn to see my F1 Ultra. I downloaded and imported the F1 Ultra lbdev file from xTool and tried to connect. I am using a fairly new MacBook Pro. Here are the things I have done:

  1. I installed the drivers as outlined on the xTool site for the F1 Ultra.
  2. I ran 'ls /dev/usb and got nothing. So I connected to my D1 and got did get a USB port in the listing.
  3. I changed the settings in the lbdev file from IP/TCP to USB.
  4. It will connect and run just fine using XCS and connecting via USB which is freaky given the results in #2.

I am using the same USB adapter on both machines the F1 Ultra connect with the newer USB-c connection and the D1 connects with the older USB connection.

I also have seen an argument whether you need the Galvo version or not, some say yes, others say it runs just fine of the GRBL version. Either way I don’t know where to go with this. Thank you for any help.

As per XTool site I believe it´s a GRBL device,

For connection issues with a Mac try connecting trough the cheapest USB2.0 you can find.

Thanks. I read all of that. I might just have to design in Lightburn and export as SVG to import into XCS.

1 Like

You mentioned USB-C. I read in a different posting that the MAC will not downshift to USB 2 and expects a USB 3 protocol at the other end of the USB-C cable, which you plugged into a USB 2 controller board.

Solution offered: Buy a dirt cheap USB expansion box and a couple of USB-A to USB-C cables to hook it up. MAC C to Box A, Box A to Laser C out.

This is supposed to trick the MAC onto switching to the lower speed USB protocol.