Connection issues with my Ruida controller and my 2020 M1 Macbook Air

I have read article after article and still no luck. I have 2020 M1 Macbook Air and for the life of me it won’t connect. I have completed the steps to connect via ethernet with zero luck. Please tell me there is a fix that doesn’t include “buy a windows computer” It looks like there is a $120 little computer that will help to create a wifi connection but that is out of stock. Please someone give me some good news!


Since you didn’t say, I will assume you are using the USB connection…

There has been a lot of usb driver issues with the mac. New type of USB (usb-c) new drivers… Isn’t it nice you have the state of the art computer…?

Have you tried to connect to the machine with Ethernet?

I don’t know your level of expertise, but I ran with a low cost wifi bridge for a number of months until the Lightburn bridge came out and I found my ‘pi’.

Isn’t as good as the LIghtburn Bridge, but it’s low cost and available from Amazon. Configure it as a bridge.

Good luck


Thank you. I did try the Ethernet option from my new MacBook and my older iMac. No luck. The Lightburn bridge is sold out. :upside_down_face:.

With the set up you described… I set up the router as a bridge?? Once that is set up how to I connect my Lightburn to it?

Again thanks so much for your reply

When it’s configured as a bridge it should connect to your lan. The Ruida needs to have it’s gateway and ip address changed to be within your lan.

Might want to write the original IP down as the Lightburn Bridge talks directly to the default gateway/ip of the Ruida.

In Lightburn, manually add the laser and use the known addresses. I think the Lightburn Bridge issue is actually because there are very few Pi computers available now and they command about 3x the regular price. I understand they have been caught up in the supply chain, microcomputer shortage issue.

Most people don’t really get how the Internet actually works as far as how machines setup and talk to each other.

I have a Linux box running Ubuntu, similar to your Mac, both are UNIX based OSs.

Ubuntu, and most other computers will normally attempt a connect by a query to the DHCP server to get a usable ip. There is generally no DHCP server when you run a wire directly from one device to another.

When I run a cable to the Ethernet port directly from the PC, I have to set my pc’s Ethernet port to that of the Ruida gateway. This is because the Ruida will talk back via it’s gateway.

If you are using that port for your lan, you could disrupt you communications with the lan. So you need either an extra Ethernet port or not using the port on that machine. You can run your lan off you wifi connection and run the Ethernet port to the Ruida…

Good luck


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.