Connection issues with USB on a MacBook Pro running Ventura 13.3.1

Why can’t I connect to the laser using the USB. I have your latest Lightburn version (1.4.00). I had no problem connecting to XCS via USB, established Wi-Fi connection, and even ran a small engraving test with no problems.
However, with Lightburn I can’t even get started as it refuses to recognize my device. I’ve tried “find my laser” with no success, I’ve tried ”create manually also with no success. I read other entries that make me think the software may have driver issues. Don’t know if it’s true or not, but I’m really at a dead end as to what I can think of to try. Is there a solution to this issue? I’m eager to get started but without device recognition, not much I can do.

If you’re using XCS there’s a PC computer somewhere.
I may need further clarity to separate the computers and the hardware to see the differences.

From a cold start, power up the Macbook, launch LightBurn, physically connect the xTool and power it up as well.

I’m going to assume that you’ve installed the WCH driver for the mac. If not, you can download it here.

In LightBurn, open the Console window and the Laser Window. Click the middle button along the bottom row in the laser window. If there is an option for a device with WCH in the name, click that one. WCH is the company that makes most of the driver chips for these engravers.

Here’s where it gets counter-intuitive, but it worked twice for me with different Macbooks.

In LightBurn, click File, click exit.
Relaunch LightBurn and watch the console window.
The last time i did this with a Macbook it connected immediately.

Please let me know if this works.

I was able to eventually connect by cycling thru (setting) each of the different COM settngs and turning Lightburn and the XTOOL D1 off and then back on, Nothing worked so I tried doing it again with the original COM setting (cu.usbserial-1440), turned both device and software off/on…and it connected. I’m still confused as to why, but i also went ahead and installed the WCH driver anyway. I guess it was already installed or if not, it didn’t hurt since I can still connect.

i’ve got another issue with limit triggers, but insofar as this issue is concerned, I’m satisfied and it can be closed.


Well I thought it could be closed, but I may have spoke too soon. I’m back to the same issue of not being able to connect, and now I lost one of my ports (cu.usbserial-1440) that i was using in my laser drop-down. I also verified that I installed the WCH driver.
I also tried what you suggested and clickexd on the ‘file’ menu item. There is no ‘exit’ in the ‘file’ menu so I went to the 'Lightburn" menu item and clicked ‘quit’. Relaunched Lightburn, no difference, same issue. I’m really curious why my port (cu.usbserial-1440) disappeared. No matter what I try, all I get is “waiting for connection…”. And I had connected successfully before.
Again, I can connect with XCS no problem via wifi and run jobs just fine. I really hope you can help me.

Screenshot 2023-06-02 at 10.55.30 AM

I was finally able to connect and I am engraving my first 5"x5" to see if everything works as it should. I should let you know I did a little research on the net and found that 2 things might have been causing me the problems of my USB issue and the laser running a previous job that I had done through XCS even though XCS wasn’t even running. The solutions seem rather obvious
now that everything seems to be running okay. To fix the USB issue of not being able to connect, I merely unplugged the USB cable and then plugged it back in. Once I did that, my old friend, com port (cu.usbserial-1440) reappeared and I connected ok. The second issue I had of the laser running a previous job was resolved by removing the TR (mircro SD) card and then reinserting it. Evidently the card automatically re-initializes when reinserted thereby getting rid of the ‘Groundhog Day’ effect experienced by the previous job. I found out this happens sometimes to the xTool D1 and D1 Pro. The TR card is only used when a wifi connection is made, which is what I was using with XCS.It wouldn’t have happened if I had been using the USB instead of the wifi, but then where’s the fun in that!

So far everything seems to still be moving along just fine. So until I run into another issue, I guess I should try to do some work. Have a great day!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.