Connection only by USB and I am using LAN

I have one LB 9.04 program on my laser connected a while ago- don’t recall any issues at all using my LAN-
I have another LB 9.04 in my office 10 ft away where I can rest my bones and cannot get that one to connect to the laser so that they both have the same setup. Second station only offers USB connection- no choice.
Can only one be connected at a time?
I see in the change log- Library now displays inch or metric, based on settings- what settings?
Thanks Gene

Yes, this is correct. You can only have a single connection to the laser at a time when using a mixed communication environment.

The setting that controls the ‘Library’ display are the ones you define in the ‘Settings’ window used for the entire LightBurn experience under the ‘Units / Grid’ section on the upper-left.

Only one can be connected at once, but there is no limit to the number of lasers you can configure in the software, and switch between. I regularly flip between multiple controllers when testing - send a job to one, select a different machine, send a different job, and so on.

Continuing the discussion from Connection only by USB and I am using LAN:

I am a bit disappointed about only one program at a time- I have used RDw for years and usually have 3 to 4 open at any one time as I do a lot of projects and experiments. Perhaps one ‘good’ program would suffice?
I have Inches/mm/sec selected and still get mm in the material library, I notice a material(in) slot in the cut window- what is the usefulness of that? It doesn’t seem to affect the Mat Lib. Thanks Gene
Sorry I seem to have screwed up the reply to the other thread.

I don’t understand what you mean here. You can open multiple instance of LightBurn, but only one can talk to a given laser at one time.

For the library, the thickness values will be displayed on inches or mm, depending on your measurement settings, and that is used to choose the material thickness that your setting is for. I don’t cut 1/4” ply with the same power I use for 1/8” ply. The only thing displayed in the library itself is thickness - what other measures were you expecting to see in inches?

I have merged the threads back together @GeneMpls. :wink:

Ok- I got the second instance connected- had to go back to choosing Ruida, then got the other options,
Maybe the pict will explain better than my poor words, Thanks gene

It should if you change the ‘Units’ as I described above. It is dynamic and will change as you change this from one (metric) to the other (inches).

Units set to metric:


Then changed to inch:


Is this not working for you? What version of LightBurn are you using? There was an issue with this that has been recently fixed. 9.04 is the latest release.

Thanks Rick. I have 9.04 altho if I check for updates it goes thru the upload again [and again]. What you are picturing is not what is happening in Minnesota right now.19

‘Check for Updates’ had a small bug causing this repeated loop that has been fixed and will be in the next release.

What OS are you running? Please post a screen capture of your ‘Settings’ window and another of your ‘Library’ showing an entry with a thickness defined.

I have Win7 pro on all my puters [we are a sign shop] 64bit on this one but the laser laptop is a 32bit.
on the screen cap I tried to type in .125 but will only take 2 digits.

The input box assumes metric, where 0.01 precision is fine. I’ll make a note to allow more decimals in imperial mode.

My point was that the ‘mm’ does not go away- shouldn’t it? If there were no units it would be better? And what does the Material [in.] below the Speed, Power min and max affect?

The mm postfix should be changed to ‘in’, yes, and it looks like I missed that one. I’ll make a note. For the “Material (in)” value, it’s used to set the Z height of the bed if you have Z moves enabled and are using the Z with absolute moves, otherwise it’s ignored. Read here:

I’ve fixed this, and it will be in the next release.

Thank you sir. You are the man. Gene

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.