Connection problem with 2nd 0.9.09 update with Mini Gerbil controller

New to the forum and still on the Trial version of the software so pls forgive me if this has been answered somewhere before.

Initially I installed 0.9.07 and all seemed fine, later on I received a update notification for 0.9.09 so I went ahead and installed that and all seemed fine. A couple days after that another 0.9.09 update notification was displayed in Lightburn so I installed that, and that’s when my problems began. The first problem I had was dropping connections within Lightburn to the Mini Gerbil. Then I started getting “Com Surrogate” errors when exiting Lightburn, Even after reverting to the first version 0.9.09 software that I am able to use without the disconnect problems, I still see the “Com Surrogate” errors occasionally. So for the moment I’m running the first version of 0.9.09 due to the connection issues I’m having with version 2. Is this a known problem or is there a setting I can change to resolve this or should I just stay on the first 0.9.09 release? Thanks

There were no changes to communication between those versions - I suspect that the issue is something intermittent and the timing is a coincidence. I have never heard of a ‘Com Surrogate’ issue before. What operating system do you use?

I’m using Windows 7 64bit. I tried to eliminate anything being coincidence by running Universal Gcode sender and haven’t had any problem with that. Only the 2nd version 0.9.09 that seems to have a problem. It homes when I open Lightburn and sometimes I can enter commands or jog around a few times before it just sit’s doing nothing. No errors in LB just takes my input and echo’s it back to me. But other times if just sits and doesn’t accept any commands after it homes. Reverting back to the first release 0.9.09 does not behave this way which is why I was asking if there were settings or something that could be changed.

It might be related to jogging. Go to Edit > Device Settings and make sure Enable $J Jogging is turned off, and Continuous Jog is turned off as well, if you can see it:


Thanks but I cant seem to find either of those settings. Any other thoughts?

It looks like those commands are already disabled for Gerbil, so that’s not likely it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.