Console Macro to pulse laser

I have a K40 with C3D board running Smoothieware. I tried to create a console macro to briefly pulse the laser, but two aspects didn’t work as expected.

My macro is simply:
M3 S100
G4 P100

The first problem was the delay seemed like the P parameter was seconds instead of Milliseconds. If so, how do I change this?
The second problem was that the laser didn’t fire (which turned out fortunate with the very long delay, although I had my hand on the beam cutoff switch :wink:

I modified the macro to do an incremental short G1 and this fired, but I’d rather not move the laser head.


here is a very fine explanation, I think

Thanks, Bernd!
That makes perfect sense. I’m still not sure about the delay period, but I try this macro and see if it works according to the description.

Not good. My system doesn’t like $32=0, returning error:Invalid statement
It also does not respond to $$, returning the same message.
I checked the config.txt file and grbl_mode true was missing, so I added it, but got the same result.
Something amiss here…
My Device is set to Smoothieware and is otherwise working fine.

Is it dependent on gerbil? unfortunately I do not know anything about Smoothieware, sorry.
There is probably a skilled user here in the forum who can come up with a solution proposal for you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.