Constant hard limit triggered

machine worked yesterday, and now constant beeps from hard triggered limits…

A loose connection or damaged wire is the most common cause.

If it’s random or sporadic yet persistent instead of constant it could be harder to find.
Wiggling limit switch wiring may help.

What else has happened near the machine or the workspace since it worked last?
Firmware setting changes can reverse the expected behaviour of a switch.

Absolutly nothing, so weird

I havnt changed any firmware, so great, a 2000 dollar machine and it has a loose wire I’ll never find

You can check these very easily with a volt-ohm meter. Assuming it’s a switch.

If your machine uses an increase in torque to identify the limits, then you have excess drag somewhere… In this case, movement by hand my help you figure out where the issue is.


no exessive drag, and I wouldnt know where to begin with all of these wires, so disapointing

It probably just came unplugged or wiggled loose. Cats also enjoy limit switch wiring.

Find the switches, gently wiggle those 2 or three wires, follow those back wiggle them at the other end.

It’s probably nothing. It might be a thing though.

thank you for that, no cats and i checked every connection, is there a way to shut the limit switch off?

Funny thing, so fired it up this morning and now it works, I just dont get it

Does this machine a detect limits by switches or current draw?


I really don’t know that one, I did see I could turn it off, but everytime I did, it would go back and turn it back on

I went to machine settings, hard limit to false, and it would go back to true

There’s a physical write switch on an xTool D1 and D1 Pro.

xTool D1 write protect switch

I know this is an important step for updating firmware but it may also be necessary for changing your settings.

Everything worked yesterday, then today… beep beep beep, it just wont trigger the hard limit trigger

wont stop i mean

I moved your other thread to this thread to attempt to keep the focus and momentum higher here.
It’s not of much benefit to split the focus and ask more than once.

ok and thank you!
So it started working the next day, and now its doing it again

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.