Constant power to laser, cant change power %

so First sorry for my english, i am french.
I have my new laser for 5 days it’s a K80 vevor ( Rudia 80W).
I have done some test and i had an issue.
At a constant speed with a power at 1%, at 20% , at 50% i have the same thing.
I have try with lighburn and also directly on the ruidia controller.
so i can’t control the power and i don’t know at witch constant power i am ( i can cut 5mm plywood with 20mm/s power ???).
Is someone had already this problem.

If you draw a circle Ø50 and set it to line, max and min power to 45% and speed to 20 mm / s., What happens then? What does your ammeter show?

Hi Sebastien, welcome to the forum.

Take you time and remember that we know nothing of what have done or anything…

The laser would not fire at 1%, so there is a minimum set in your controller, which you cannot go below.

You did not mention speed. With a Ruida, it controls the laser output, part of that power computation involves the speed.

Some photos would be nice, especially of ‘what’ it’s ‘not’ doing.

Good luck.


Here a picture. You can note that there is no différence. The speed was 300mm/s.
And yes, i know that normally at 1% i should have nothing but it s not the case

Puissance= power

Thanks for the translation…

Do you have a voltmeter you can check the PWM output of the controller. It doesn’t look like you have any ‘power control’.

If so you can check Lpwm1 (I think) and set it for 20%, that should give you 20% of 5v or a volt. 50% power should be 50% of 5v or 2.5 volts.

Do you have a mA meter or one on the laser power supply (lps)?

Can you give us some values…?

What is the lps rating? 80 watts or higher?

The controller has ‘default’ settings for minimum/maximum. If you attempt to go above or below it will limit it with the specified range. So you are getting the ‘minimum’ to which the controller is set. Mine was set to 10%. I should say ‘should’ but something is not right…


Hi , at 20mm/s and 45%, the circle is cut, but the circle is cut also at 1%

Hi i have check the in of the power supply, at 20% i have 1V, at 50% it’ 2,6 V,

What do you mean?

You advised it was 20mm/s at 45%…

You should check ‘Edit → Machine Settings’ and check your ‘start speeds’ Along with laser max and min.

Any speed below that will give you minimum power. You can set max and min equal.


Hete the machine vendor setting,
I set the min and max power at 45% the circle is cut,
I set the min and max power at 1% the circle is cut

yes, yes and yes, i have found the problem.
There is a micro swtich ( very little) on the PSU next to the Rj45 port, i move it to the top and now semms working better. Thanks

That is nice to hear. What function does this little switch have?