Continuous Jog causing Z axis issues?

Not looking for sympathy just a solution…I have an Omtech K40 with the K40+ board (SmoothieWare)I’ve been using a motorized Z axis for awhile through Lightburn without issues. I just had a TIA (mini-stroke) generally I’m doing great no real deficits but I have a few areas that are a bit cloudy . I tried to move my Z axis in Lightburn today and nothing happens. If I swap leads for X or Y steppers to the Z connection neither X or Y steppers will move . If I connect Z leads to Y or X connector Z stepper moves perfectly. I find mention of “continous jog” causing issues with Z axis movement true or not I don’t know… Heres my problem, I cant remember if I made changes somewhere before the TIA. Continous Jog is supposed to appear below Move Keys but doesn’t. Could I have disabled it somehow and dont remember? Z axis is enabled in Lightburn
Lightburn is 1.4.00

What kind of Z mechanism do you have on the K40? I’m not familiar with these typically having a motorized bed and seems unlikely you’d have a motorized head.

Was this an add-on?

I don’t believe Continuous jog is an option for Smoothieware.

Can you do the following:

  1. Take a screenshot of Edit->Device Settings
  2. In Console run these commands. Can you describe what happens when you do this?
G0 Z-3
G0 Z3
1 Like

Sir I appreciate you taking time to help me!
I did build this Z axis bed as an add on, until now its worked great.
I’m working on getting a screen shot…It says it goes to clipboard but I sure cant find it. but i will get figured out. I tried G91 G0 2-3 G0 23 it came back with unsupported command, Ive never entered any code before so good chance I screwed it up? You are correct the head only moves on Y and X.

Can you copy and paste the commands? Note that it should be the letter Z, not the number 2.

I entered the codes with Z not Two…(Feelin a bit foolish…) It didnt give any error msg but didn’'t do anything I could see…BUT while doing it I hit the run Gcode button in the Laser window. I saw Z100 just that nothing else. I deleted that now Z axis works fine.
THANK YOU for your help. Pretty obvious at this point I need to pick up at least some basic knowledge on GCODE use. Can you recommend any YouTube video(s) that may be better than others? or maybe a website “GCODE for DUMMIES” perhaps .

This is a bit confusing to me but if you’re back in business that’s the important part.

I’m not familiar with any specific video that would be a good introduction. If you’re somewhat technical or familiar with CNC operation then reading through the G-Code overview on LinuxCNC site is a good start.
G Code Overview (

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.