Converting to a MKS DLC32

I received the MKS DLC32 today… The display was showing backwards and kind of jumbled so I tried flashing the firmware as suggested on the github…wow it has ended up being a fkangular (#when you are fked from multiple angles LOL) experience. The main page firmware ( firmware )links go 404. The tool to upload the firmware rar is bad. (I tried using the one on https://diode-laser-wiki.com/documentation/firmware-update/ and the supplied firmware) the supplied firmware is bad, no display nor able to connect to a grbl controller. I did try a sculpfun one and it loaded and was able to be controlled through grbl. There was no display though. So Now I am trying to find a decent firmware that works with the MKS DLC32 V2.1. LOL wow its been fun

It seems the Wiki link is referencing an older repository name. Try this:
MKS-DLC32/MKS-DLC32-main/firmware at main · makerbase-mks/MKS-DLC32 · GitHub

thanks for the reply. When I use the latest bin for the ts24 setup and connect to a grbl console tis is what I get:

I am using the sculpfun tool as all of theirs won’t open

What does this mean? Please elaborate.

Are you certain the Sculpfun tool is compatible?

Looks to me like you’re not getting a proper flash completed. Perhaps try erasing the firmware before reflashing.

I also have an mks laser tool for the esp32 that looks like yours on your page i have used it when I erase and then load any of their firmwares that screen capture is what i get. But if I load the sculpfun firmware it loads more onto it (theirs (MKS) is only loading 3 registers and sculpfun loads about a dozen). Sculpfuns loads just fine. So I don;t believe it is a hardware issue. it is wierd

Did you follow the flash instructions?

As you can see with the screen shots it is connecting and says it is writing


Have you tried first Erasing from that tool?

yes I have.

When i use the firmware for sculpfun its uses a ton more registers and GRBL works on it:

esptool.py v3.1-dev
Serial port COM8
Connecting…_
Detecting chip type… ESP32
Chip is ESP32-D0WD (revision 1)
Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
Crystal is 40MHz
Panel-0 MAC: a0:a3:b3:6e:79:fc
Uploading stub…
Running stub…
Stub running…
Configuring flash size…
Erasing flash (this may take a while)…
Chip erase completed successfully in 1.2s
Compressed 4194304 bytes to 530004…

Panel-0 Writing at 0x00000000… (3 %)
Panel-0 Writing at 0x00012428… (6 %)
Panel-0 Writing at 0x0001c4b8… (9 %)
Panel-0 Writing at 0x0002b2e5… (12 %)
Panel-0 Writing at 0x00046b0d… (15 %)
Panel-0 Writing at 0x00051319… (18 %)
Panel-0 Writing at 0x00056b55… (21 %)
Panel-0 Writing at 0x0005cad7… (24 %)
Panel-0 Writing at 0x00062a89… (27 %)
Panel-0 Writing at 0x000683ad… (30 %)
Panel-0 Writing at 0x0006d4bf… (33 %)
Panel-0 Writing at 0x00072a13… (36 %)
Panel-0 Writing at 0x00077c6d… (39 %)
Panel-0 Writing at 0x0007d218… (42 %)
Panel-0 Writing at 0x00083a0f… (45 %)
Panel-0 Writing at 0x0008bd38… (48 %)
Panel-0 Writing at 0x00092163… (51 %)
Panel-0 Writing at 0x0009786c… (54 %)
Panel-0 Writing at 0x0009cd95… (57 %)
Panel-0 Writing at 0x000a225a… (60 %)
Panel-0 Writing at 0x000a7a5e… (63 %)
Panel-0 Writing at 0x000ad4a4… (66 %)
Panel-0 Writing at 0x000b32d9… (69 %)
Panel-0 Writing at 0x000b8f19… (72 %)
Panel-0 Writing at 0x000bf139… (75 %)
Panel-0 Writing at 0x000c4ce3… (78 %)
Panel-0 Writing at 0x000caaf7… (81 %)
Panel-0 Writing at 0x000d1495… (84 %)
Panel-0 Writing at 0x000d721c… (87 %)
Panel-0 Writing at 0x000dd464… (90 %)
Panel-0 Writing at 0x000e335f… (93 %)
Panel-0 Writing at 0x000e90ec… (96 %)
Panel-0 Writing at 0x000eeb64… (100 %)
Wrote 4194304 bytes (530004 compressed) at 0x00000000 in 53.3 seconds (effective 629.9 kbit/s)…
Hash of data verified.

Leaving…
Staying in bootloader.

Firmware successfully flashed. Unplug/replug or reset device
to switch back to normal boot mode.

In that case are you certain you’re using the correct firmware for your board?

Alternatively, consider using the FluidNC firmware although I believe you may lose display support using that firmware.

Like this?

If so, the display is not compatible with the firmware.
You have the TS24 display and the firmware is for the TS35.

Here’s a link to when I had a similar experience:
https://forum.lightburnsoftware.com/t/flame-detector-on-mks-dlc32-board/107643/1

Yes I am sure it is the appropriately listed firmware

First as my excuse I was recently diagnosed with neurological pathway issues that sometimes make it hard for me to process information and grasp visual or audible cues… I wasn’t downloading the firmware correctly I was right clicking and selecting “save link as” Instead of clicking on raw… I should know I have even had projects on github. So I big dumb dumb head

1 Like

Glad you got there in the end. That nuance with github has bitten many folks. Seems there should be a better way of handling that.

it was entirely my fault, this neural pathway thing has caused me to lose all the hearing in my left ear in 4 months and still discovering all the other “joys”. I am quite familiar with github but silly me…

hello john, I’m randy, the guy building the Cherokee beast laser. Don’t feel bad, I was having problems getting my laser to work right. I too am running a
DLC32 V 2. Had lots of problems getting the laser to fire correctly. Sometimes I
had problems with X & Y steppers. I fought that thing for some time and a few days ago I remembered that the only thing I had not checked was my DLC to USB jumper cable. Pulled out a new cable and that was the problem. Everything works correctly now.
Randy