Copying directly from Adobe Illustrator to Lightburn no longer working

For nearly a year I have been able to copy and paste directly from Adobe Illustrator into Lightburn. Within the last few weeks I no longer have this ability. I am using the most recent version out Lightburn and Illustrator.

Thank you for reporting this. You are the first to identify this is an issue. Which OS, and anything else that might be unique about your setup? Anything additional to help us reproduce is appreciated. :slight_smile:

@LightBurn

Windows 10, Ruida version of lightburn. It appears I have the clipboard setting correct in Illustrator.

Do this for me:

  • Run LightBurn
  • Go to Help > Enable debug logging
  • Run Illustrator
  • Create a simple graphic
  • Copy it to the clipboard
  • Switch over to LightBurn
  • Quit LightBurn

There will be a file in your Documents folder called LightBurnLog.txt - attach it here and I can have a look at what format Illustrator is putting on the clipboard and see if we can potentially load that. I don’t have Illustrator here, so most likely they have clipboard data that LightBurn already handled.

I can’t paste as well. This would be a killer feature.

See log: https://pastebin.com/0012t2Xv
Also screenshot: https://snipboard.io/Os1V7D.jpg

The log explains why. Illustrator is saying the data is just plain text, but it’s actually an SVG file in XML format (which is technically plain text, but it’s dumb of them not to tag it as SVG data). I can make the text paste code pre-check the content to see if it’s actually something else.

1 Like

This should be fixed in the next release. I don’t have illustrator, but I’ve tested by copying the text content of an SVG from notepad and pasting, and that works.

1 Like

Thank you. I just test new version. It works great! Almost :slight_smile: Only one problem that pasted shapes are not scaled correctly. I.e. if I copy shape 350x200mm from AI in Lightburn it paste as 262.493x149.992 mm size.

That’s likely because it’s being generated in ‘pixels’, not mm or another proper unit of measure. LightBurn uses the InkScape definition of the px size, being 96 DPI. It looks like Illustrator uses 72 DPI. See if there’s a way you can control the SVG output to be in proper units, or at 96 DPI.

I did research online and unfortunately there is no setting in AI for this. And it’s not like Adobe will implement that in this decade lol. Would it be too much trouble to implement the SVG DPI thingy setting in LightBurn so we can set custom DPI scale?

You’d need to change it every time you imported an SVG from somewhere other than Illustrator. Is there a DPI setting in Illustrator itself? (I’m curious if it has a global setting that might work)

In Illustrator preferences, under “File Handling and Clipboard” untick (ie deselect) “On Copy: Include SVG Code”

Then in my test the Copy/Paste into lightburn comes in at the correct size.
I don’t know what other effects this has on other applications or functions but worth trying to see if it solves your problem

True, but most people (like my company and our business partners) only work with one vector draw application. So “other than Illustrator” for us does no exist :smile: Industry standard is Illustrator or Corel. This feature to copy and paste would be big time saver because we do loads of one off odd jobs and each time we have to save .AI file and import in to Lightburn.

No. This is know issue for some time now: https://graphicdesign.stackexchange.com/questions/128038/change-illustrators-native-svg-resolution

If I do that, paste does not work at all. Not on the MacOS anyways. In the logs Im getting:
09:21:55.041 D: Clipboard data present:
09:21:55.042 D: ()

You cant set illustrator to work in “real” dimensions like mm or inches instead of px?

I’ve logged the request in our bug database. It’s easy enough to put it on a switch.

1 Like