Corners are cut off


I’ve assembled the Y400 lasercutter from Further Fabrication that uses a Ruida controller. I’m still in the early stages of fine-tuning it. Currently, I’m facing an issue where the corners are getting cut off, and my circles appear with some straight edges.

Here’s a picture for reference:

Any idea how I can fix this?

I would go over all your moving parts, make sure the whole machine runs freely and smoothly. Check all your pulley wheels and check that any set-screws are tight. Also try a run with the laser running very slowly and see if you get better results. If its a mechanical problem you should see a difference at different speeds.

I already checked them, but I will check them again.
The idea with different speeds is also great.
I will let you know about my findings.

If the orientation in the photo is left to right along the x-axis, them this looks like backlash on the x-axis. So check the x-axis drivetrain for slop or play.

The attached file can help identify backlash, and how bad it is.

BacklashTest.lbrn2 (197.6 KB)

Yes you are right, x-axis runs from left to right on this image.
I will give this a try with the test file and also check for some issues on the x-axis.

Alright I tried the following:

  • tighten up the x-axis belt
  • reduced the speed to see if there are too high forces/accelerations
  • increased the current of the stepper driver
    all with the same result.

Here is video of the triangle which shows the issue. (I was not able to upload it the video here, so I uploaded it in my nextcloud).

And I fired up the backlashTest file with the following result:

I think these issues are strongly related to each other and are not hardware related.
There is no problem to reproduce the paths with slow and high speed.

Maybe you can get more information from the BacklashTest.

Thanks for your help.

Everyone (myself included!) who builds a CNC machine develops a huge blind spot when it comes to finding problems in its hardware. We’ve already looked and found nothing, so it must be a software problem.


Judging from the test, the X axis has many millimeters of backlash and the Y axis has a few. This is most likely due to a loose setscrew in a pulley or shaft coupler.

A copy-n-paste from a recent thread:

Start at the X axis motor, find each setscrew, and try to loosen it with a gentle counterclockwise turn: if it wasn’t tight to begin with, it will be very easy to loosen.
When you find the loose screw, loosen it by one turn, then rotate the pulley or coupling around the shaft while tightening the screw. Finish tightening it so it’s centered in the flat part of the shaft and firmly snug.

Then do the same for the Y axis.

There can be other causes, but look for the simplest ones first.

You are probably right.
I already had an issue with the setscrews on the y-axis.
As you mentioned I totally forgot about my issue in the past.

I will check again all screws.

What makes me wonder is the precision of this error.
It does not matter where I place it or how fast I go. It always shows the same shape.

But before I try another software I will check all screws :sweat_smile:

Thanks for your help :blush:

@ednisley thank you very much for your advice.

You were totally point on :smiley:

Here my new backlash test:

I guess that I need to tighten up the setscrews on the Y-Axis again.

Does it make sense to use screw lock glue?

Gonna put another notch in my lipstick case for this one! :grin:

Absolutely, after you’re sure the screws are locked in the middle of the shaft flat.

I favor low-strength threadlocker, rather than the permanent formula, because I know I’ll be changing something in there just after the glue sets up forever.

Happy lasing!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.