Correspondance between size on screen and size in cut

Hi, I have a laser since a couple of months and want to cut some design/logo I made in Illustrator. The laser is a 3018Pro with Arduino / GRBL. I tried various free softwares and had always the same problem. That’s why I came to Lightburn hoping I could solve it, but the problem persist and I can’t find the solution. The problem is : the size of my logo is much reduce when cut with the laser. I can’t manage to decide/control the size of my cut !?! My design/logo has a specific size determined in Illustrator, but when I import it in Lightburn, the job done with the laser is much much smaller. Where should I go to decide the size and have a proper correspondance between the size on the screen and the size of the cut !?! Thank you so much for your help !!! I checked in the forum and found beginings of answers, but I still Don’t know how to deal with that answer : “You typically don’t configure your controller using your Lightburn - you configure it and refine it when installing it, then you connect the correctly-configured machine to Lightburn”.

You are telling us that your machine has never run as you’d expect. This will need to be addressed prior to successful use with LightBurn. Once you have your hardware and firmware set correctly, items are placed on the LightBurn workspace and can be sized as you choose using the Height and Width controls for that object.

Let’s start with your firmware, Please post what is reported in the ‘Console’ window when you first connect using LightBurn. Next, type $$ into the console - hit ‘Enter’ and post the entire results here for review as well.

This sounds like your steps/mm are not set correct.
You can adjust them with the $100 for the X-axis and $101 for y-axis.
Draw a square 20x20mm with the laser, measure the actual size and readjust accordingly.

Continuing the discussion from Correspondance between size on screen and size in cut:

Hi Rick, first: Thanks for your reply and help!
So, when I open Lightburn with my machine connected, this appears in the Console:

Waiting for connection…
Grbl 1.1f [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
error:9
[MSG:Caution: Unlocked]
ok
Waiting for connection…
Waiting for connection…
Grbl 1.1f [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
error:9
[MSG:Caution: Unlocked]
ok

Then, after typing $$ in the Console:

$$
$0=10
$1=25
$2=0
$3=6
$4=0
$5=0
$6=0
$10=1
$11=1.000
$12=0.002
$13=0
$20=0
$21=1
$22=1
$23=3
$24=25.000
$25=500.000
$26=250
$27=2.000
$30=1000
$31=0
$32=0
$100=80.000
$101=80.000
$102=80.000
$110=8000.000
$111=8000.000
$112=100.000
$120=250.000
$121=250.000
$122=20.000
$130=500.000
$131=500.000
$132=200.000
ok

Hello Roy, thanks for your help!
I tried that already, but I can’t go above a limit which is not enough for the size I want. My motors make noises and stop. I guess I have to respect some caracteristics of the motors and can’t put any values!?! I’m exploring the notions of Leader screw pitch, Steps per revolution and Micro stepping setting. But I don’t know if this will help? If you have an idea :wink:

First of all, you need to turn on the laser Mode by changing the value of $32 to 1.
This is done by typing into the console $32=1

And now pls. Do as I proposed, draw a square of 20x20mm engrave or cut it, measure the real distance and change the values of $100 and $101 with the new calculated steps. The formula is as follows:
Current steps / measured distance × 20mm
This value you need to store by typing into the console again:
$100= the new calculated value
(this would be for the X-Axis)

Do the same for the Y-Axis, but this value must be stored under $101

I will do that and let you know :slight_smile:

Ok Roy, so the drawing square of 20mmx20mm is cut as a square of 2mmx2mm. So, I applied your formula and changed the $100 and $101 values to… 800 ! Then I tried again to cut it and the motors made a crunchy noise and stopped :frowning:

After resetting the $100 and $101 value at 80, it works again, but still 10x smaller than wanted.

so yor square comes out 2x2mm?

Yes… 10 times smaller than what I could expect !

Than 800 would be right, but obviously your stepper motors stalls. So either you need to adjust the stepper current or check the belts, grease the linear rails etc.
Maybe someone else having this kind of mill can help you with his settings.

I don’t think it’s a problem of grease. As I said, I probably have to take in consideration a kind of ratio between these motors parameters:
_Step angle
_Leadscrew pitch
_Microstepping
I will explore that.
But you mentionned Stepper current !!! What is that ? Seems interesting.
If anybody can help with those things… Thanks !!!

By calculating the new steps as I described, all these things like ratio, microsteps etc. Are already taken into consideration.
So if your axes move free and easy and nothing is preventing them from moving. (Which could also be a to tight belt) the only thing left would be the motor current. You need to know what kind of stepper motors are built into the machine and how much A they can get. You also need to know which stepper drivers are installed and you need a Multimeter to adjust the current.

I Don’t have belt, only screws, and they move freely.
But following your last message, you gave me an idea and tried to increase step by step by 80 $100 and $101 (step/mm) and reducing the speed (mm/min) proportionaly. Starting at a speed of 6000 (which was by default), I ended at a speed of 600 (mm/min) and a step/mm $100 and $101 at 800, as wanted… and it works !!! So now, my drawing square 20mmx20mm is cut as a square 20mmx20mm !!! Wonderful, thank you !!! I will try now with my Illustrator design.
Would it be that the problem was : increasing the step/mm and keeping a high speed was too much for my motors !?! Is there a rule of proportionality betweeen the speed and the parameters of the motors ?
Anyway, thank you very much Roy ! I can now go on with my project :slight_smile:

Great that it works right now, even so 600mm/min is very slow and you most probably end up with probs when rastering images. I would estimate that either your stepper motors are by far too weak for the machine or that the current is set to a much too low value.

If I would be you, I would check what kind of NEMA motors are build in and chech how much Ampere they are able to take. Than I would check how the drivers are set.

I will check all that ! Thank you !!!
My machine is a chinese CNC 3018Pro, sold with the motors, so I guess they are adapted to it !?!
They are : 42BYGH34H-2A-13D
Now I know that it works with $100 and $101 at 800 with a speed at 600, I will try to increase the speed to check up to which speed it crashes !?!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.