Couple of basic questions ref; origin / stopping


(Eamonn Burns) #1

Hi guys,

Can someone give me a bit of an understanding as to why origin and home cannot (or can they?) be the same thing?

I’m running a K40 with C3D - and obviously my bed is geared up for when i press home, it goes to 0,0 - i’ve then setup spacers/etc, so the material goes on square and lines up with it…

However it seems that lightburn runs from origin and so my cuts are in the wrong location on the material? very new to it all so correct me if im wrong!

and secondly, i’m not sure why it does it, but lightburn allows you to cut layers that arent ‘shown’ so as a result i mistakenly cut a layer that i wasnt suppose to - but when i pressed stop - it went for a considerable time before it stopped - isn’t there an emergency stop button of some kind? obviously i can turn off the power to the laser, but c3d keeps moving.


(Blake Bartlett) #2

image

I think you’ll want to change that to “Current Position”, to make it start from wherever your laser homed itself to.

As for show/output, those work (I think) identically to RDWorks, and function as intended. Sometimes it’s nice hiding parts you’re not currently working with, even though you’ll be cutting them. Also my laser has an e-stop button, but I’m using a chinese red/black and not a c3d.


(Chris Leitch ) #3

On the stop function. I’m guessing that you’re running the smoothie firmware on the cohesion3d board. When you press stop lightburn stops sending further gcode instructions however there will be a number of commands already buffered on the controller which will be executed as smoothie doesn’t have an absolute stop command. This would work as you expect on the grbl-lpc firmware.


(Eamonn Burns) #4

Very helpful - as a relatively newcomer i think i’d value grbl-lpc more! :slight_smile:


(Chris Leitch ) #5

There are some compromises. You can’t use the C3D lcd or run jobs from the memory card however the scanning speed is faster for engraving than smoothie.


(Oz) #6

You say, “When I press home my controller goes to 0,0” - it doesn’t, it goes to the home location where the switches are, which isn’t necessarily 0,0. If you’re using a C3D in a K40 the home location is 0,200 (rear left), while the origin is 0,0 (front left).

Despite being documented on C3D’s site (in bold), and set as the default in the software, people still get this wrong constantly. So if you’ve set the “origin” as rear left, it’s incorrect, and why your cuts are going to the wrong spot.

Show/hide is useful when editing designs that have intended overlaps, or if the design is relatively complicated, to reduce the amount of stuff you might accidentally click while trying to edit, speed up the display, etc. Sometimes vectors end up behind a bitmap and it’s nice to be able to shut it off temporarily to edit the things it’s hiding.


(Eamonn Burns) #7

Appreciate the reply albeit direct

I don’t actually understand the difference between origin and home and I’m sure you’re far more knowledgeable than I ever be and I set it correctly as per the instructions.

However my question was around that 0,0 is where the head stops when you press home it matters not whether it’s 0,20 on a physical measurement.

It is the only point known to the laser, because of, as you say the end stop is there.

Thus I line my material to this point using 3d spacers which helps me know where I am.

Blake above however kindly provided me with the help that I needed to get lightburn to work with my work flow which is great.

In terms of the show/hide remark, I understand it’s purpose, what I fail to understand is why the software would allow a layer to cut that isn’t visible on the screen.


(Oz) #8

Apologies for that - The way I read what you’d written sounded very much like your output was wrong because you’d set the home location wrong (and it happens daily).

Regarding show / hide, this is a direct mimic of the workflow in RDWorks, which is what LightBurn was originally modeled after, and done that way because it’s what those users were accustomed to. I may revisit this, as it’s come up once or twice before.


(Eamonn Burns) #9

thank you kindly :slight_smile:

The forums a bit akward to ask follow on questions (unlike facebook where its just part of the course) but hopefully you won’t mind; is there a hotkey for ‘jog’ (cant see one on hotkeys.md) and / or is there a way when you select a tool to keep it selected?

I’m using jog to move the head across the bed for alignment purposes, but by the time i adjust and go back to re-jog its deselected and back on the pointer tool? just trying to learn not a big issue!


(Rick James) #10

Here is a PDF version of the LightBurn Hotkeys. Jog controls do not have hotkeys at this point. LightBurn provides jog/movement via number keypad arrows in the next release.


(Eamonn Burns) #11

Thanks Rick, thought there wasn’t one but the number pad would be great :slight_smile:

Is there a way to stop the jog tool being deselected automatically?


(Oz) #12

There isn’t. I could add an option to adjust the timer length, but it was done this way because a few people complained that they’d left it on the move tool, forgotten, and inadvertently moved the laser away from the correct starting point on a workpiece.


(Eamonn Burns) #13

Hi Oz

I’m sure you know you can’t please everyone all of the time! :slight_smile:

Your reasoning makes perfect sense, the minor inconvenience of reclicking is worth it if it saves a work piece down the line :slight_smile:

Thanks again


(Rick James) split this topic #14

2 posts were split to a new topic: Help with Install


(Ray Kholodovsky) closed #15