CP210x no connection

Lightburn will not connect thru the Silicon Labs CP210x uart bridge. Other software connects to the CP210x and functions correctly. We are using an Openbuilds X32 motion controller. The Wifi connection functions properly in Lightburn with the OpenBuilds X32.

The chip does not really play a role. As long as it provides a COM port, LightBurn can use it. If you have the correct driver and selected the correct COM port, I don’t see any reason why LB should not connect.

We have tried it on five different computers with both paid and trial versions of lightburn.
All we get is waiting to connect. Lightburn works with the FTDI version of the X32 controller.

The CP210x connects and produces a comport. The CP210x comm port works with other grbl software. Just not with Lightburn.

Maybe show a screenshot of the full LB window including the laser window and console as well as device manager once the board is connected.

There one thing you can try: go to device settings and toggle the “enable DTR signal” option. This sometimes helps with connection problems.


Sorry to step in.
I may be wrong!
Regarding drivers :

I believe CP210x are not 100% equal, CP210x has 3 kind? of drivers
CP2101 has a newer universal driver 281KB, and version 6.7.4 has 175MB, maybe for different Windows OS, or likely Win10 Win11 has a lot of “INFO” built-in… but it would be good to identify the chip correctly. Because I believe Lightburn needs the VCP drivers.

For further investigation you could try this tool from Microsoft or Usb Sniffer.

1 Like

I checked the hardware. The chip is the CP2102.

Check if you are using windows built-in drivers or Universal, and maybe try this one.

I have tried several different driver linke.
I tried the drivers on the link you sent.
LightBurn still will not connect to the comm port.

In post 6, it shows the device, does it not?

If the device is showing, the driver is working…

If Lightburn can’t connect, it’s likely some type of protections issue…

Can you run Lightburn from a supervisor (root) account?


I have also tried running LightBurn as administrator. Still not sure why it will not connect.

You setup your machine as GRBL, what type is it connecting with other software?
Also check if other software connects through the same com port.
The com port 53 belongs to which device?
Today OpenBuilds released new drivers.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.