CR-Laser Falcon - laser wont fire

Hi there,

I have just recently got the CR-Laser Falcon (5W) and it initially printed perfectly off the memory card it came with. I created a few small print jobs and they printed fine too. I lost the files on the memory card and haven’t been able to recover them, so im now using USB-C to print directly from my laptop, but the laser wont fire. It goes through the motions of framing and printing the image, but nothing prints without the laser firing obviously. Any clues what I need to try? Thanks, Susan

Hi Susan,

Hard to tell from here but I would check the wires to the laser unit and also the speed and power settings of your print. Maybe share a printscreen of the settings of the file you are trying to print?

HI Jaap,

Thank you very much for responding. I have attached a picture of the job and my settings. I hope this helps?

I have not touched the wires to the laser since it last fired, so I don’t think its that

Is this message of any significance?

e[0;31mE (834250) gpio: gpio_isr_handler_remove(480): GPIO isr service is not installed, call gpio_install_isr_service() firste[0m

Hi Susan,

I’m not an expert but there’s nothing wrong with your settings as far as I can see but the error code is most likely causing the problem. Did it work before while connected to your laptop or was this the first try? Did you install your laser unit within Lightburn? Maybe delete the installation file in Lightburn and connect again? Where did you get this error message?

Hi Jaap,

I’ve only had it a few days and tried a several files, including the one I’ve shared, from the memory card and everything worked perfectly. For some reason I then lost the files on the memory card (possibly from swinging it between a Mac and and HP) and it’s not worked since. I then updated the firmware as suggested by the tech team, and set up Lightburn on the HP using a USB C cable. It’s going through the motions of framing and printing the image, but with no laser.

I’ve cleaned the laser head.

That is the message I get when I abort the ‘print’ because the laser isn’t on/firing.

I am a complete novice so I have no idea what to try next.

It looks very much like updating the firmware has gone wrong, maybe you can try that again. Did you get an error message when you updated the firmware? The other thing you can try, just to rule out that option, is to replace the USB cable. But from the information you’re giving, it looks very much like something went wrong with the firmware update.

Your laser worked perfectly when using the memory card, so the problem is your USB connection to your laptop or your settings in Lightburn. Looking at the screenshots, your laser is still disconnected. What I would do is:

  1. Reinstall your laser in Lightburn
  2. try a different USB cable
  3. try a different computer
  4. try to update the firmware again

Print a test file after each step to see what it does… When this all doesn’t do anything, I’m running out of options. Maybe some more experienced users could help you here. Let me know what happens!

When this all won’t solve the problem, I’m out of options. Maybe a more experienced user here will have some other suggestions. Perhaps superfluous information but some links for setting up your laser in Lightburn that might help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.