Creality CR-10 Falcon COM Port Issue!

I’m having a frustrating issue with my Creality CR-10 Falcon laser engraver. When I try to connect it to my computer via USB and use LightBurn, the software can’t detect the device at all. I’ve tried manually adding the device in LightBurn, but there are no COM ports available to choose from.

Here’s what I’ve done so far:

  1. Checked the USB Connection: The USB cable is securely connected, and I’ve tried different cables and USB ports on my computer.
  2. Installed Drivers: I made sure that the necessary drivers for the CR-10 Falcon are installed on my computer.
  3. Restarted Everything: I’ve restarted both the computer and the CR-10 Falcon multiple times.
  4. Manual Device Addition: I attempted to manually add the device in LightBurn, but as mentioned, no COM ports show up.

Despite all this, LightBurn still doesn’t recognize my CR-10 Falcon. I’m running out of ideas and would really appreciate any help or suggestions. Has anyone else encountered this issue and found a solution? Any advice on troubleshooting steps I might have missed?

Thanks in advance for your help!

Have you installed the CH34x driver?
https://sparks.gogo.co.nz/ch340.html
Read this doc also.

Thanks for this, unfortunately, I already have that driver updated.

Windows PC?
Type devmgmt.msc in Win search
Expand Ports (COM & LPT)
Connect a working memory pen to if USB ports work(you may had triggered USB open collector protection) and check in Windows access to memory pen content.
If everything is working connect your laser USB cable while hearing system sound and checking if Laser COM port appears in Device Manager.

Yes, Win10.

Also, that is the same copy/paste steps that Creality Support provided as well.
I went through those steps, I tested on 3 laptops, and all of the USB ports work and tested with USB drives, tested various cables (AtoC & CtoC).

However, still no connectivity when plugging the engraver into the laptops.

I did update the firmware, I tried to update drivers. Everything was up-to-date.

I even checked BIO/UEFI settings - those all seem to be good/non-issue.

I will say this: I did read about potentially using the ‘Drivers for Win7’.(# ESP32 Win7 VCP drivers
INF files that enable ESP32-S3 Serial/JTAG peripheral and TinyUSB CDC stack operation as VCP on Win7/8.)

…not sure if that’s a troublshooting step I need to consider?

On the Laptops are you checking connection in Lightburn or device manager?
Use only USB-C to USB-A cables.

Both (Lightburn and Device Manager)

Just a quick update:

I’m at a loss here. Chat Support (‘support’ is kind of ironic, as they were anything but) suggested going through the Win7 Drivers step, despite being a Win10 machine.

So, I’ve tried to go through these steps, but they don’t provide any real tutorial/steps to get through that.

After a few hours, still no progress.

Reached out to Support again, they ultimately said their ‘engineers’ need to researched. Asked I email them the following:

  • Photo / Short Video showing the printer’s issue (not exceeding 50MB)
  • Photo of your your payment showing Order # & Purchase Shop
  • Photo of printer’s SN or QR code
  • Email address you used to place your order

(feel like I should include the comment this rep made: Actually not the first time but the only option we have if it does not detect the COM ports even after updating the drivers is to report to the engineers cause either the engraver has a faulty port or there’s a different underlying cause that we do not know, that’s why I asked for those information earlier cause that’s what is required to make a report.)

I emailed them with only the relevant details to the matter.

Getting closer to just returning this junk

1 Like