Creality Falcon 2 - 22 W is crashing into the frame

Hey everyone! I’ve had my Falcon 2 for maybe 6 months and it’s worked fine so far. Then a couple days ago I went to run a file. I put the SD card in place, turned the machine on, pressed the Frame button… all was good… then I hit the start button and the module flew back to the home position and crashed into the frame. In the video below it doesn’t crash as hard as it does occasionally.

I updated the firmware, I tried running older gcode files that have worked before, turned the machine off and on, I tried saving my gcode with different “Start From” coordinates (before this failure I have never used anything but the default, “Absolute Coords”). What’s weird is that it frames normally. And I can press the home button on the machine’s interface and it goes to the home location and soft taps against the limit switches. But, when I hit “play” the Air LED goes from green to red and it flies home.

I reached out to Creality and they told me I needed a new air pump. I told them the air pump was working fine and they told me I needed a new laser module. Cool.

One thing I hadn’t considered until recently was that I store the laser on its side on some hooks on my apt. wall. Could that have somehow messed with the tip-over sensor and now the machine (which has been sitting on a flat surface for over a week now) is freaking out?

Any help on this would be greatly appreciated. Thank you much!

Do you run the machine exclusively with SD card?

Are you able to connect to your computer and run through USB? I think there’s value in understanding if the issue is with the interface from LightBurn or if it’s unique to SD card function.

What happened when you did this? I assume the same behavior as shown in the video? If so, that implies a change in the basic function of the laser.

It’s not clear to me how the machine handles the framing internally. It would be instructive if you could run framing from LightBurn.

Does it touch each switch once, back off, then re-touch the switches, then backs off for a final time?

Did it do this earlier when it was working correctly?

Storing the laser that way might expose it to some mechanical stresses but I don’t think it’s related to tip-over.

If you can connect your machine to LightBurn can you run these commands in Console and return output:


I exclusively run it with an SD card. But, you’re absolutely right that getting information on how it works in real time is critical, so earlier today I ordered a 60 ft active repeater USB cable in order to get from where my computer is to where my laser cutter has to be. I don’t have a laptop. :slight_smile:

That is correct. The same behavior as in the video.

Agreed. As soon as I get that cable I’ll post back with more information.

That’s correct as well! It taps the limit switches twice and then stops.

OK, so the video I posted was taken before I updated the firmware. In that earlier state, the Air LED was always flashing yellow/red no matter what and it never appeared to affect the ability of the machine to print. Now that I have updated the laser module firmware the Air LED correctly displays whether or not air is flowing (I’ve tested to be sure). Except when I press the play button, the LED goes from green to red and it flies home.

I was hoping you’d say that.

Awesome! Thank you so much for posting this. I should receive that extender cable by next Tuesday and then I will cross my fingers and run that input and do more testing to see if I can sort out what’s going on.

Thank you again!

Good evening! My apologies for the delay.

I received a long fiber-optic USB cable which I connected from my computer to the the USB cable that came with the laser, then to the laser. So far there aren’t really any signs of life. In the console I only see “Waiting for connection…” and G0 repeating down the page. That happens whether or not anything is plugged in.

There are a number of articles already on Creality Falcon lasers having a lot of trouble connecting to Lightburn and they are… complicated. I’ll continue to research how to make the connection work.

You may want to try connecting a known working device with that cable to confirm that it’s working predictably. You don’t want to be in a situation where you’re testing two components of uncertain behavior.

Thanks! I thought of that as well. The cables work with other devices. :frowning:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.