cu.Bluetooth-Incoming-Port only option on Apple MBP

Hi folks - need assistance.
I am currently using a diode laser on a Windows laptops with zero issues. However, I want to convert my working machine to my MacBook Pro. I have Lightburn installed and in the device drop-down, my only option is “cu.Bluetooth-Incoming-Port”. I have Bluetooth turned off and quite honestly have no idea what this is. I have tried to reinstall the laser, but same results.
When I view the System Report and the laser is plugged in via USB, the report shows it is recognized as being there, as opposed to when it is unplugged and not connected.

My MBP is older - it is 2013 model that is maxed out on OS 10.12. Could that be the culprit?

If the laser is detected in System Report but is not made available to LightBurn it’s most likely that you need to install a driver.

Not sure what model of laser you have.

If you can upload a screenshot of the System Report for the specific device is I can review the vendor information.

Mine shows the same Bluetooth option, but I also have the serial port listed. No idea what the Bluetooth item is but it always defaults. I’m guessing you need your driver installed/updated. I’m running Monterey.

Thanks for the quick replies.

Right after I posted this, I dug deeper into the prior posts and saw that a driver was the suspect. I saw a link and followed it. After reading that post, I opted to download it and give it a try.

IT WORKED! And the test file I ran was a perfect output!

This opens up a work of possibilities for me and my little shop.
Thanks again for the replies. Even though I read them afterwards, your answers were spot on.

Here’s the link if anyone else needs it:

I selected the

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.