Cut direction won't change?


I need to change the direction that my work is cut out, but no matter what I do to the direction on lightburn, the preview and the cut is always the same way, which is the wrong way for me… Any ideas? Thanks

Which version of LightBurn are you using, and what are the settings for the cut layer?

I tried a couple different things, and it looks like kerf offset discards the direction of the cut. I’ll make a note to try to fix that. In the meantime, if you offset the shape manually using the offset tool, and remove the kerf, it should work. Lead in / out doesn’t affect it.

Thank you Oz, yes this is the first time I’ve used a kerf offset on a job… That must be it, I’m using the most current version I believe, I’ve only had it around 2 weeks. Thanks for the update I’ll fiddle with my job for now. :+1:

The bug has been fixed for the next release.


Is it by any chance set to cut outside shapes clockwise and inside shapes counterclockwise? That’s the way my plasma software runs.

LightBurn doesn’t care about winding order - it actually verifies everything by doing full geometry checks.

The problem here was that the direction was set by the cut optimizer, and the code that offsets shapes for kerf always produces the same winding order. We have to check the output, and reverse it if the user wanted the opposite direction.

Hi Fred, not in this case as it was a single shape with no inner or outer shapes but where you can manually reverse the cut direction in lightburn, as oz said the kerf setting was overriding this. Thanks :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.