Cut Inner Shapes First

I’ve read the posts past of when this was reported, but the answer is not hitting me. For some reason, on these two native shapes drawn in Lightburn, when cutting it does not cut the inner shapes first. I am on the current release. Any suggestions?

I have “Cut Inner Shapes First” set.

lb3

If they’re on the same layer and you haven’t set object priorities, then turn off “Order by Layer” and “Order by Priority”.

Interesting, I was able to reproduce this finding of yours but now when i try reproducing it once again so i can share the sequence in which it happens - i fail.

You likely imported this as a DXF. There’s a chunk of debug code that slipped into the last release that was never supposed to that assigns the index of the object to its Cut Order Priority value when importing DXF files. We use it internally for tracking down import issues.

If you imported a DXF file, the ‘Order by Priority’ setting means that everything is being cut in the order it came out of the DXF. If you remove that setting, or select everything, go to Shape Properties, and enter ‘0’ in the ‘Cut Order Priority’ it will fix it.

The other possibility is that your lines are just lines, not closed shapes - if the shapes aren’t continuous closed loops it’s impossible for the software to decide what’s ‘inside’. Your shapes are grouped, but 4 grouped lines are not a rectangle - ungroup and see if they’re disconnected.

There was parts in this file from a DXF file, but I am fairly certain I drew these in LB. I will confirm though, because this project has my brain fried. Thanks (as always) for the quick and informative response.

For the record i made mine, same shapes, natively in LB and got the same result - outer cut before inner for one shape - the other was doing what it supposed to do - cut inner first). i was trying to reproduce this to see what was i doing (selecting all then group or grouping each then selecting all, etc…) but couldn’t reproduce what happened once.

Well, I drew the same shape again and this one is cutting in the right order. There’s some buried bug in there, but I can’t seem to find the pattern yet. Moving on for now!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.