Cut optimization help - its cutting out of order

Hi Guys. Hope this one is not as simple as the last issue I had… still feel stupid from that one haha. I tinkered with this for a couple days just to make sure I was not missing something insanely stupid like the last issue… I can only take so much face palming per week!

This one is a bit complicated to explain, so I made a video. In short, I need engraving to be done before cutting as my laser will drop the finished pieces in to a bin after the cut layer. I think everything is setup right, and if I cut a single item it works just fine! But the moment I use the array tool to do more than one in a row it changes the order of the cut layers. See the attached video. And please do not make me facepalm again. My nose is getting sore. :smiley:

(Had to upload it to youtube): lightburn question - YouTube

Please let me know what you guys think. Thanks!

can you share your project so i can try to reproduce it?

I had not saved it, but just reproduced it and saved it… so hope this works. test project.lbrn2 (239.1 KB)

Ok i will try then i let you know

In menu edit, select open shapes, delete the result of this selection (lots of very little noise) - donetest project.lbrn2 (239.1 KB)

1 Like

I just tried this… There was a small bit that was selected, so I deleted it. Tried again just to be sure… and nothing selects, so good. But the problem in the video still persists. Furthermore, this same thing happens on all my parts currently - and another part (the one I just happened to be working on when I saw this reply) has no open shapes at all… and it still has the same issue.

don’t ask but… in the test you gave me, if you got the last and place it in first position you obtain exactly what you want, first engraving then cutting
LB preview

I am not sure what you mean by that? You mean mirror it? Problem with mirroring is the part would be backward and not fit where it is supposed to…

i hope like this you got the point…
LB prev 2
There is something wrong in duplicates, something that there isn’t in the last one

Ok I see. I have already left the shop for the day, so I will try this tomorrow - but one thing remaining - its engraving the entire row instead of engraving them one at a time (order by: Group then Layer). I will play with that tho and see if I can figure it out. My laser is 1300mm wide, so doing an entire row at one go is tricky… sometimes when scanning it can slip by 1mm - its rare, but it happens. If that happens when doing an entire row we lose the whole row. If it happens when doing 1 at a time, then we only lose the one.

in any case, I will try this tomorrow first thing when I get to the shop. I do not have lightburn installed here at home :slight_smile:

1 Like

When you make the array, try the ‘virtual’ option. I removed the excess stuff from ‘select open objects’.
The array worked properly. To get it back to objects you have to ‘flattened’ it and it also worked properly.


The right way should be to clean the original first, then make copies of it with the array function. However, I cleaned your finished file and then got the result you wanted, engraving first, cutting out items afterwards.

1 Like

By cleaning you mean to delete any open shapes correct? I did do that… and also tried the virtual option. Neither work. I just got to the office today and will be spending some time trying to figure this out.

1 Like

I have played a little more with this task and found that I can get the desired result when the optimization settings are set as in the picture. (it is not necessary to remove any “noise” first).

This works only if “Order By Layer” is on top of this list. if both Order By Layer comes after Order By Group Lightburn will disregard the layer order.

We Pressed REPLY at the same moment :slight_smile:

I will check this shortly, but if I have only Order by Layer selected wont it engrave the entire row at one time? If so that will not work.

This laser is a chinese (Bogong Machinery model 1325) and it has a tendency to “skip” 1mm sometimes. And once it does, the laser head no longer knows where its at in relation to home… e.g. if it does that when its engraving a single item, we lose that one item - but so long as I space items more than 1mm apart, the next item in the row will be fine. If its doing the whole row at once tho, the whole row is ruined… which is a very expensive mistake with the material we are using.

So my goal is to engrave and then cut out each item one at a time… so that any that have mistakes affect only that single item and not the entire row/column.

ok, ya. That ignores groups completely. :confused:

Of course, it’s unfortunate that you lose a line once in a while. But if it is not several hundred pieces you make at a time, I will divide the task into two sections. First engrave it all from layer 1 then cut out all the item with layer 2. It takes a little extra time but in return you do not lose your production.