Cut-order issues

Hi All,

I’ve got an odd problem with “Order by Group” not working the way I’d expect.

My drawing:

My plan is to (in order):

  • Fill the Blue,
  • Offset-Fill the Green, and
  • Line (cut) the red.

My Cuts/Layers list is thus as follows:2

As my laser drifts slightly over time, I’d like to do this group-by-group. Each individual blob is a separate group (the 17/08 + circle + square in blue is part of the adjacent group).

So I have the optimization settings set thus (I’ve also tried a TON of other permutations):3

The Alt-P preview results are not what I expected.

It starts well, doing the blue Fill then the green Offset Fill in the 17/08 group.

But then things get odd: rather than doing the red Line around the 17/08 group, it moves on and does the green Offset Fill of all of the other groups before returning to do the cut of 17/08.

It then does the blue Fill and red Line of the of each of the remaining groups.

What I want/expect it to do, pet the settings listed above:

for group in groups:

What it actually does:

  • Group 17/08 Blue Fill
  • Group 17/08 Green Offset Fill
  • Zig-zags between these three:
    • Group 19/20/09 Green Offset Fill
    • Group 18/19/09 Green Offset Fill
    • Group 20/21/09 Green Offset Fill
  • Group 17/08 Red Line
  • Group 19/20/09 Blue Fill
  • Group 19/20/09 Red Line
  • Group 20/21/09 Blue Fill
  • Group 20/21/09 Red Line
  • Group 18/19/09 Blue Fill
  • Group 18/19/09 Red Line

Is there supposed to be a “Fill all shapes at once”/ “Fill groups together”/ “Fill shapes Individually” setting for the Offset Fill operation? It’s greyed out for me.

Note that I’m not using my real laser profiles above: my laser is in New Zealand, but I’m currently in Ireland. I usually make my Lightburn files and then send them over to my Dad in NZ who puts in his actual cut profiles for the material he uses.

Lightburn 0.9.20, Windows 10 Pro v2004, build 19041.685.

Thanks in advance for your assistance,


I’ll have to look and see why I removed the option. Technically there’s no reason you shouldn’t be able to use the grouping options with Offset Fill, but it’s a brand new option and I was likely trying to cut down on the amount of work to get it up and running.

Fair enough, thanks Oz.
Happy New Year!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.