Cut Selected Graphics Not Working

So, I used to use this all of the time in versions before 1.3.x. But, this seems to have broken at least for me in 1.3.x and above. I just tried this is 1.4 and it still isn’t behaving correctly.

I have a shape somewhere within the Lightburn workspace boundary, but my laser head is sitting at 0,0. My material is also sitting at 0,0. Instead of moving my design, I want to use the “Cut Selected Graphics” option and the “Current Position” start position.

I can frame the job and it frames correctly. When I try to start the job from Lightburn, I get the error “XY Frame Over size. Work Paused.” This used to work in versions prior to 1.3. Is this a bug or am I missing something?

If it frames properly, then the overscan is going to take it out of the machines working area when it actually runs… that’s probably what the error means… I have a Ruida, so it’s not the exact message but same game…

I don’t use current position, because I want the origin at a particular place, not where the head ends up, so I employ user origin, which must be set on the console with a Ruida. Current position is useful, in certain situations, but I prefer user origin.

Most of these controllers have options on where the head will end up… 0, 0, a set user origin or leave it where it is, same as current position…

Good luck


1 Like

I don’t think that’s the issue. I’m cutting at slow speeds. If I change it to absolute coordinates, and leave the design where it’s at, it will work.

This may not be apples-to-apples depending on the current position of the laser head.

I believe the “XY Frame Over size” error comes from the controller itself, not LightBurn. So if this is a change in behavior it would be due to a change in what LightBurn sends to the laser.

Can you try downgrading and check this exact design to see if it behaves as you expect?

Could it be he has not enabled use selection origin?

It’s going the wrong way and from my time, I find that it’s usually related to his start from/job origin settings.


Apparently it was just too close to the origin. Moving the laser head away ever so slightly fixes the issue. I tested it in both 1.2.04 and 1.4.00 and they both behaved the same way. I guess I had never had my material right on the axis origin before when trying to use that option.


One of the issues with these, is you sometimes have to believe what it’s telling you … at leas that’s what it computes…

Great it’s going…


To assist, you can flip ‘Show traversal moves’ in ‘Preview’ ON (green) to see the overscan applied by the Ruida for the job. Helps to see the Slop Over. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.