Cut Settings editor

When using a scan angle of 45degrees, the pictorial representation in the Cut Settings editor shows the machine travelling sw to ne but the preview screen shows the etching going nw to se as does my laser machine. Is this a bug?

That’s right, I can reproduce your statement. In the preview window during simulation, the engraving is mirror image in relation to the set angle.

Do I need to submit a bug report?

Normally I would think that the LightBurn people capture the content of our conversation, but it does not hurt to report it as a bug and that is probably the correct way to go.

Please excuse our delayed response. :slight_smile: I may not be reading this as you intend, so help guide me if I’m off track here. If I understand, I am not seeing the same.

Below, I show a 100mm x 100mm square set to ‘Fill’ @ a 45º ‘Scan Angle’, with a fairly large ‘Line Interval’ to make it a tad easier to see in ‘Preview’. I see both the ‘Cut Settings Editor’ window and the ‘Preview’ window represent traversal moves in the same direction.

[macOS, LightBurn 1.0.02, Ruida Profile RR]

I see you list more than one laser system. Do you observe this with each Device Profile, or one in particular? Which version of LightBurn (version number) on which OS?

Share what you see and we can go from there.

Hmm. 1.0.02 with Linux Mint gives me this, which does look wrong…

OMT, Ruida, LR machine origin

I am using lightburn 1.0.02 on a windows laptop, this is what I get


Yeah, yours is wrong also.
What corner is your machine origin?
Might not make any difference but maybe… ?

I experience the same with my system, MacOS BS on Macbook Pro and Gerbil STM profil. The same goes for my Linux Mint PC also with Gerbil profile. The direction of engraving in the preview window is reversed. (LightBurn 1.0.02)

Thank you all for this feedback, will investigate further. Does the output to the laser produce and traverse in the same direction as shown in the Preview?

The preview and the laser itself agree, its just the representation in the cut settings editor that is wrong.