Cut Shapes tool on Text

I’m seeing something strange going on with the Cut Shapes Tool.
I can put in the text, draw a rectangle with one of its sides crossing over the text, apply the Cut Shapes routine and it cuts the text in two pieces,
However, the actual locations of the cuts are where the anomaly starts.
Tried twice with slightly different rectangle locations and it appears in both attempts.
A picture is worth a thousand words but to highlight, see the attached images.
It’s not cutting where I think it certainly should be cutting.
The “t” has a sort of reversed skip. Also, notice the first “s” appears to be correct but the final “s” has some skipping issue. Zoom in to see what’s happening.


I can reproduce and confirm this behavior. I want to say I remember seeing something about this but can’t recall the specifics.

You can work around this by converting the text to path before doing the cut shape operation.

Would be nice if this worked predictably with text, however.

Thanks for confirming. I knew about the workaround but didn’t really want to have to go that route. But thinking about it a little more, what good is half of a word or phrase anyway. Ha!

I wondered if it’s just related to certain fonts and maybe the original direction their individual perimeter paths were drawn but seeing what was happening on the “s” at different places appears to negate that theory.

Again, thanks for looking into it.

@StevenM and @berainlb, thank you for drawing this to our attention and confirming. I am not seeing the same, so need a bit more from you both, if willing. What are the exact steps you have taken to produce these results.

Here is what I get. I made duplicates of my cutting shape and place on different Tool Layer, just to show and check the location of these cuts. I show both ‘Fill’ and ‘Line’ shapes cut results.

Here’s a setup.

I’ve setup the cut shape in the attached file. If you apply the cut shape as-is it should result in the issues above.

This is on Windows 11. Font is Arial.
cutshapeoddity.lbrn2 (73.0 KB)

1 Like

I was not as through as I should have been. :man_facepalming: Sorry. When pulling my example apart a little, I now see what you are experiencing. Thank you. I will generate a report for the Dev Team to review. :slight_smile:

Edit: Report generated.

1 Like

My first go was Arial as well so I tried two other fonts in Line mode and got the same result.
However, I went and repeated the process with the layers in Fill mode to see how it played out knowing the cut “should” heal when in Fill mode. Seems to be working properly. See attached.


1 Like

Thank you for this additional information. This matches my results as well. :slight_smile: A report has been made and the Dev Team is aware and will investigate further.

1 Like

This has been fixed for the next update.

1 Like