Cut size different from frame size

So I have an Ortur 2 40x43 cm and I had to move from PC to Macbook. I re-installed everything and looked like it worked. I can move the laser freely etc… I have created a quick test file with just a square, a simple square and if I run “frame” the size on canvas is right. As soon as I press play the laser makes the square but super tiny! I can’t figure out for the life of me what is the problem. File attached.
test.lbrn2 (2.8 KB)

Can you run this gcode in LightBurn? It should make a 100x100 square at 500mm/minute. It is set to a very low power so should not mark.

Can you confirm whether or not the square is roughly 100x100mm?

square_100x100.txt (265 Bytes)

it is set to 100% power and it is supposed to do a 100x100mm square but does more like a 10x10mm square

EDIT: just saw I misunderstood Berainlb. Will run the Gcode asap and report back

You ran the gcode I linked and that’s what you got?

This is funny. I run your Gcode and definetly “draw” a 100x100cm square but when I changed the power from 1% to 100% didn’t leave any mark

How did you change the power? By modifying the g-code?

This indicates that there’s something wrong with how g-code is being generated by LightBurn on your machine.

This is odd.

Can you Save Gcode for the design that you posted here using a .txt extension and post here? I’m curious what you’ll get.

Can you also take a full screenshot of Lightburn with the design loaded?

Yeah modified the Gcode adding two 0 to the 1%.

here is the gCode from that file

test_gcode.txt (284 Bytes)

and the screenshot

Can you Save gcode for your own design and return results? I’d like to understand why it’s trying to cut small.

I’m also curious why increasing S value is not affecting the laser light. That makes me think you have multiple issues going on.

Can you take a screenshot of Device Settings.

And also return the output of these commands in Console:


This is what I got running your command







[MODEL: Ortur Laser Master 2]

[OLF: 140]

[DATE:13:36:28 - Dec 31 2020]



Target buffer size found




















































This the device settings

so I run this Gcode

; LightBurn 1.2.01
; GRBL device profile, absolute coords
; Bounds: X104 Y144 to X288 Y324
G00 G17 G40 G21 G54
; Cut @ 1000 mm/min, 100% power
G0 X104Y144
; Layer C00 Pass 1 of 3
G1 Y324S1000F1000
G1 X288
G1 Y144
G1 X104
; Layer C00 Pass 2 of 3
G1 Y324
G1 X288
G1 Y144
G1 X104
; Layer C00 Pass 3 of 3
G1 Y324
G1 X288
G1 Y144
G1 X104
G1 S0
; return to user-defined finish pos
G0 X0 Y0

And this is the result

I don’t see anything unusual in your Device Settings or GRBL configuration that would explain either the lack of power or the sizing issue.

Can you save gcode for your design and post here? I’m hoping that at least explains the sizing issue.

The power issue would imply a hardware issue of some sort.

Just to confirm, can you run this g-code? It’s been modified to 100% power.
square_100x100_S1000.txt (281 Bytes)

I just posted the Gcode of my design with a picture of the result. Do I still need to run yours?

Can you try it? Trying to understand what might be the difference in how this is running.

So far I understand:

  1. My original gcode at 1% power results in proper dimensions but no burn
  2. Updating original gcode to 100% power results in no burn
  3. Your jobs can burn but produces small dimensions

A few things:

  1. Can you run my modified g-code?
  2. Can you try disabling Constant Power mode and rerunning. Does anything change?
  3. Can you try running the gcode that you generated using the “Run gcode” function? Do you get different results vs running with Start button?
  1. the modified Gcode makes a small square
  2. Disabling conastant power does nothing
  3. Running my Gcode through command still make a small square
  4. I have switched to another laptop that I used to use fine, no changes to the settings vs when I was using it and still makes a small square
    Could it be something hardware related? like with the motherboard? I have also updated the firmware with no luck

Ok finally got something! Until I use 65% of the power does a fantastic job but as soon as I go over that cuts tiny.

Could be that I am using a garden power cord extension plus the power supply is not the original one (just a random IIRC that I found at home)

This seems likely to me. The exact mechanism of how that would work I’m not sure. In any case I’m going to guess power delivery related. Whati is the power rating of the power supply?

I have an Ortur Master 2 and the power supply is 12v1amp

My Olm2 has a 12V 3A power supply

The current rating is likely the issue. Switch to something at least 3A assuming you have stock laser module.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.