Cut stopping halfway through code

Hi, I’m new to using LightBurn, although my Emblaser has had many years of use. I am finding that any code generated by LightBurn has a spot where the cut simply stops - most notably on curved elements such as circles, or even hexagons. Suppressing the first line of gcode seems to solve the problem (G00 G17 G40 G21 G54).

In the stream I get the following error:
error: Unsupported command
On or near line 0:
It seems odd that Lightburn is struggling to read code that it generates…

Any ideas on what is causing the laser to stop? I am using the Mac version of Lightburn. Thanks in advance!

Which Emblaser model? That error is coming from your controller, not LightBurn. It’s possible that it doesn’t like the extra zero in G00. Can you try changing just that, and then using Run GCode on the file?

If that doesn’t do it, you can split that line into individual commands and run it again, and then when it stops and gives you the line number, we’ll know exactly which command it didn’t like.

Thanks for the quick reply!

I am using the Emblaser 1. Upon a bit of further investigation, it turns out to be the G40 in the gcode: Tool radius compensation off.

Do you think it would be possible to try a setting in the tool where the radius compensation is turned on, but for a very small offset? (0.01mm for example?)

It’s possible that the version of GRBL used doesn’t support radius compensation at all, which might explain why it doesn’t like that command. Having said that, I’ve looked, and GRBL says that it’s supported: https://github.com/gnea/grbl/wiki/Grbl-v1.1-Commands#g---view-gcode-parser-state

Which version of the GRBL firmware do you have on that controller?