Cuts and scans aren't lining up - how do I fix this? (Ruida)

Before you play with settings too much, make sure your rails are all clean and lubricated. If you’ve had the machine for a while and don’t clean it regularly, gunk can build up on the rails or in the bearings. Any binding in the motion system can mean the steppers have to work harder to do their jobs, and at some point they’ll slip.

If you’ve done that already, there are a few settings to play with that can help:

Idle speed is how fast the laser head moves between cuts.
Idle acceleration is how fast it gets to that speed.

Min and Max acceleration control the acceleration during cutting. (I don’t have a good understanding of what Min acceleration does).

image

Stepper motors have poor torque at high speeds, but high torque at low speeds, which makes this a little more complicated.

If you reduce the maximum speed, but leave the acceleration, it will move short distances quickly, but long travel moves will take a little longer. If you reduce the acceleration, but leave the speed alone, it will take longer to get to full speed. Short moves will take a little longer, but long moves will still happen faster.

In my experience, lowering the acceleration usually does a better job of preventing slips overall, and reduces the amount of shake you get from the machine when doing jobs with lots of small rapid jumps. Try dropping idle acceleration by 25% and running a low power test. If that doesn’t work, drop the idle speed 25% too. If that doesn’t help, do it once more. My red/black machine from China shipped with very “optimistic” settings, so depending on where you got yours, it might need a bit of tuning.

Also searched as: layers don’t line up, motors skipping steps, misaligned layers.

1 Like