Cuts being repeated after finishing

Hi all, thank you for having a look. Hope you can help me out!
So I recently purchased LightBurn in order for it to work with my Snapmaker 2.0.

I have a problem that whatever I tell it to cut, after finishing (LightBurn progress bar is done), the laser cuts the whole image again (just one pass), mostly on top of the already cut parts, but sometimes in seemingly cuts it offset to the left and down, as if the pivot goes from my default (bottom left) to the center of the images to cut.

I tried cutting default LightBurn shapes with just 1 pass, 5 passes, Illustrator files and Images but it always adds the pass after everything is done and I just can’t seem to figure out why or if I have a setting selected somewhere that causes this.

Does anyone have any ideas or tips on what I can do to solve it? I really like LightBurn so far but this is really getting me stuck with my projects.

Thank you!

Check that you do not have double lines, or two copies of the cut file open

Post a copy of the offending file :slight_smile:

ExampleFile.lbrn2 (14.1 KB)

Thank you for your response! This is a file I just created. What happens when I start it:

  • It cuts out the shape (1 pass as configured)
  • returns to origin
  • ?repeats the shape?

EDIT: Here’s a video: https://youtu.be/TxPf_dgTYZg

EDIT2: A full day of troubleshooting and I can’t solve it. No matter what the file is (AI, SVG, PNG, Lighburn shape). I did notice that If I add a second shape it will only repeat the first shape. I’m so confused and frustrated by this software. (Still way better than Luban though).

Thank you for the ideas. I double checked and also tried a new file. No double lines and only one Lightburn instance open unfortunately.

Thanks… I don’t see anything wrong with the file. It run OK on the preview. I assume it runs OK on your preview? That’s what it’s generating code to do, so it’s like a WYSIWYG (what you see is what you get) editor it’s displaying machine movements.

You video is really missing the beginning. It should start before your machine starts and let your machine come to a stop. It almost looks like some kind of reset.

I sincerely doubt that LightBurn is doing this. Tons of people have hammered this software for this kind of issue. Especially drawing circles.

This might help, is to save the ‘gcode’ file and post it. (File-> Save GCode) I can generate gcode here and compare them.

I think we need to identify if it’s a hardware or software problem. Generally not configured properly.

What does that mean?

What LightBurn version are you using?
Does this only happen on cuts?
If you draw square first, inside a circle, what does it do?
What is the ‘pass’, a layer or …?
Does your machine have ‘home’ capability?

Half of the solution to the problem is understanding the problem. So hang in there… :slight_smile:
Maybe something here will give us a hint.

I also notice you are running 100% power. I hope you don’t drive your car that way.

Thank you for your help! Sorry about the video quality, was rather hard to film inside the enclosure while also pressing Start at my desk. The only thing cut from the video I see is where it moves from the Work Origin (center left of the circle) to the position where it starts cutting.

Do you think it might be the Snapmaker messing up the GCode? I used the setup from this forum (Snapmaker 2.0 A350 Setup Guide) to connect LightBurn and also double checked all those settings today.

What I meant with ‘Always adds the pass after everything is done’ is that once the machine has finished cutting what I want it to cut, so whatever I configure in LightBurn, it goes to the Finish Position and then starts cutting the same shape again once (so 1 pass, even if for example my LightBurn project has a shape that I’m cutting in 16 passes).

I am using LightBurn version 0.9.24

If I draw a square first, then a circle around it, it cuts both shapes according to how I’ve set it up, and then returns to cut the square 1 pass.

With a pass I mean the amount of times it cuts the same shape, as per the layer setting ‘Number of Passes’.

Yes my machine has home capabilities. Cutting head goes top left (X + Z), material plate (Y) goes all the way forward.

Regarding the power. I put it to 100% so I could see the cuts clearly with just one pass (as that’s the easiest way to see if it has this error, I can just follow it and if it repeats the shape my ‘bug’ is still there). For this material I normally use 5 speed at 55% power and 12 passes.

Do you have it set up to do them how you drew them or by layer order? Start it with the square, then the circle… then it does the ?

You seem to indicate that it does N + 1 number of passes as set in the layer? If you have two layers set for 2 passes each do they both do 3 passes?

Maybe I’m tired, but I think that indicates the home position to be the back left (top left). Meaning the setup procedures first photo of LightBurns in the setup link is wrong. Don’t know if that’s an issue or not, but something smells. They don’t sound related… but you should find out the correct config. I think you stated it’s the back left.

Hang in there with me… :slight_smile:

Thank you for sticking with me. I appreciate it!

So I tried a couple of things:

Scenario 1:

  1. Drew a circle. Layer 1, 1 pass.
  2. Drew a square. Layer 2, 1 pass.
    Machine does: start at origin, Cut circle, cut square, go to finish position, cuts circle, go to finish position.

Scenario 2:

  1. Drew a circle. Layer 1, 1 pass.
  2. Drew a square. Layer 1, 1 pass.
    Machine does: start at origin, Cut circle, cut square, go to finish position, cuts circle, go to finish position.

Then delete circle.
Machine does: start at origin, cut square, go to finish position. No repeat cuts in this instance! (could me a workaround for now). If I save this file and restart Lightburn, machine is back to it’s old habit and repeats the cut on the square.

So machine does: N + 1 passes for only the first drawn shape. Could it be something wrong with the machine? I have to go to work now but I will try fully factory resetting and reinstalling the machine to Lightburn when I get back.

Thank you for your help!

Edit: I keep running into more issues like power not being changed by LightBurn etc until I restart the SnapMaker 2. What a piece of sh*t that is for the price it’s being sold at. I spent another couple of hours trouble shooting and just nothing solves it. I am probably going to return it because it wasted enough of my time and I refuse to use the trainwreck that is their crappy Luban software. Thank you for all your help though!

Edit2: For anyone having the same problems; I found that by not setting a Finish Position in LightBurn solves this error (tried it with LighBurn shapes, AI and PNG files, different settings). As soon as I press ‘Set Finish Position’ it wil do the extra pass.

So the issue is solved? If I read your last entry correctly.

One of the issues in developing and maintaining software like LightBurn is that it drives a plethora of different machines. The development group doesn’t own them all and cannot conceivably test them everywhere.

Saying that, the ‘Set Finish position’ only tells your machine when to park itself when the job is over. Again something smells here…

If you purchase the software or not, I’d notify support only because it’s a potential issue that could be software. Only because it’s an ‘innocuous’ type of bug for most people that’s probably rare. But it is wise, and the people at LightBurn are that, they will try and look into it I’m sure.

Send them this also and the the link to this thread. I think this will help them locate the issue… The last one being key.

Don’t forget to mark it solved, if so.

Take care good luck. There’s lots of people here to help about anything Laser like.