Cuts incomplete and incorrect alignment

Video example

I have been trying to get a cut on my new machine, and it is not behaving.

I have the machine up and running and have tried for over a month to make a good cut with the new board. When I go to cut, the machine does not honor the cutting perfectly, like my old board does. A simple example is included in the video above.

I tried two different methods. I created a rectangle in Lightburn. When I go to cut it, I make it based on the center position. When it cuts you see it starts high, and then cuts the side correctly, but then over cuts the rectangle.

In another example, I stacked two rectangles, and when I go to cut it they do not line up. It cuts the first rectangle, and then it does not cut the relative second cut correctly. I also have had the laser only cut 90% of the square. The last bit does not connect. What am I missing?

Thank you.

Oh man, that thing is losing steps so bad you can hear it scream.
Find the acceleration settings and turn down to something reasonable.

Ok. This is just cutting paper at 1.75 inches per second at 5% power. It does the same thing even when I am cutting acrylic at .3” per second and at 35%. It doesn’t honor the start at center selection.

It’s not the cutting speed that’s the problem, it’s the acceleration. When that thing first starts you can hear the stepper scream while it goes nowhere. It WANTS to go to the right spot to start, but the stepper is stalled because it tries too accelerate to fast. It very clearly audible right at the beginning when it’s trying to move to the lower right. When steppers lose steps or stall they make a very distinctive gritty almost “gear grinding” sort of sound. I didn’t even need to watch the video (I did), just the audio is enough.

It could also be motor current - if it’s too low, you won’t get enough torque from your motors, and this will also cause them to slip and miss steps.

It also appears that you haven’t edited the size values in the config.txt file to correspond to the actual size of your laser work area, and you might need to calibrate the step lengths for each motor axis as well. C3D’s LaserBoard is pre-configured for a K40 - if you’re using it in a different machine, you will need to alter the settings.

In the config.txt file on the SD card, you’ll find:

acceleration  (how fast, in mm/sec^2 to accelerate)
alpha_max     (the maximum travel on the X axis)
beta_max      (the maximum travel on the Y axis)

You’ll need to adjust those at a minimum. And possibly these too:

alpha_steps_per_mm  (motor steps required to move one mm on the X axis)
beta_steps_per_mm   (motor steps required to move one mm on the Y axis)

Great to know. Where is the documentation on the config file? This machine is an upgrade of an mle-40 machine. I will look around, but any help is appreciated.

Google “Smoothieware configuration file”

Thank you! I hope I can get this working.

Do I want to move the values up or down. I am assume down. Trying like half the number of mm/inch?

Down - Drop the value by about 25% of what’s there, as a starting point. If that doesn’t skip, go up about 10% from there until it does, then back off again.

1 Like

I got the quality of the cut to behave. I am now having a scaling issue with the new settings. When I cut a 1" x 1" square it is scaling it to .75 x .75 due to the new steps_per_mm new value.

alpha_steps_per_mm 118.18125 # Steps per mm for alpha stepper 157.575
beta_steps_per_mm 118.18125 # Steps per mm for beta stepper 157.575

How do I correct this issue. I attempted to change this value, but it has the biggest impact on the cutting quality. There is also no size or width scale on the config file. I did setup the bed size on Light burn, and without messing with the config file it was cutting the correct size.

Thank you again for your help.

Dunno, but IIRC, using inches on Smoothie causes issues with accuracy as internally everything is metric and you end up with a lot of rounding errors compounding.

It’s not going to make a 25% error, I suspect, but it’s recommended to use metric, not Imperial Roman units. :slight_smile:

Good to know in the metric scale. I will run some tests on that to see if changing my bed to mm will help.

Thank you again.

You changed the steps/mm by 25% and that is why everything is 25% smaller. Put the Steps/mm back to 157.575 and it will be correct for your K40 laser machine.

I figured as much, but should I only reduce the acceleration for the correct cutting?

Yes reduce the acceleration setting, but leave the steps at the 157.575 value.

I have a problem now when I increase the power in the setting on Lightburn the two layer cut does not line up. This has been very frustrating. At 2.36 speed and at 5% power the item cuts as expected, but when I put the final material in it and set the same speed but higher power, 80%, the two layer no longer cut in the correct alignment.

From the support email:

If the lower power setting works, but higher power does not, it’s very likely that you have electrical interference of some kind. It won’t be a software issue.

  • Make sure the laser is grounded properly. Often the ground wire is attached to a screw that is bolted to the frame after painting, and the paint prevents a good electrical connection.

  • Make sure the board itself is NOT grounded to the frame. Use plastic standoffs if you can.

  • Use a good quality USB cable with ferric beads on at least one end, if not both (those are the bulges in either end of the cable, about 1" long, 1/2" around).

  • Check that the wiring inside the laser is relatively neat, and the wires going to the high-voltage power supply from the board don’t coil around anything else, as this could possibly induce noise in other signal wires.

Also, when posting speeds, please include units. 2.36 mm/sec is very different than 2.36 inches/sec.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.